
Agilent VEE Pro 8.0 New Features 

Watch Window 

Watch Window allows the user to view and edit values of variables and terminals when debugging. The program 
can continue execution incorporating any changed values.   

When you click  button on Toolbar, or select View  Watch Window, the Watch Window dialog box 
appears as follows. 

 

See Watch Window for more information.  

Examples 

Datatype.vee, Globals.vee, Terminals.vee  

Code Completion and Code Insight 

Code Completion and Code Insight greatly benefits any user who writes formula objects by reducing keyboard 
inputs and the need for memorization and external documentation. You can stay in your context, find the 
information you need, insert language elements directly into your formula, and even have Agilent VEE complete 
your typing for you. See Code Completion and Code Insight for more information.   

Color Syntaxing 

1. Comments are marked Green, Constant Strings are marked Dark Red and keywords are marked Blue. 

2. Errors in a formula are marked by red wave lines. 

3. Brackets are marked by grey frames. 
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Objects Supported by Code Completion and Code Insight  

Programmatic Properties 

Programmatic properties helps the user to create better GUI faster. It allows users to GET/SET properties of VEE 
Objects, .NET objects, and COM objects at runtime. See ProgrammaticPropertyDemo.vee for a quick demo of 
this powerful new feature.   

The following table shows properties that can be SET/GET programmatically. See To Change Properties 
Programmatically  and To Change Object's Name and Scope for more detail information 

Example 

ProgrammaticPropertyDemo.vee  DemoTabIndexChangeDemo.vee  

Minimap 

Minimap is an outline map of the entire detail view with a red rectangle box indicating the visible portion. To open 

the Minimap, click  button on Toolbar or choose View  Minimap. An example of Minimap is shown in the 
following figure. 

   Objects Supported 

Code 
Completion 

  .NET objects 

  Named VEE Objects 

  COM objects 

  Built-in Constants 

  Built-in Functions 

  Records 

Code 
Insight 

  Member functions of .NET and 
COM objects 

  Local UserFunctions 

  Imported UserFunctions 

  Built-in Functions 

  Imported Remote Functions 

  Imported Compiled Functions 
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The red rectangle shows the relative location of the visible area in the entire detail view. Just one click on the 
Minimap, you can quickly jump to another location in the detail view. See Minimap for more detail information.  

Home button 

Agilent VEE 8.0 adds a new Toolbar button Home , which moves the upper left corner of a program to the 
upper left corner of the context (Main, UserFunctions, or UserObjects). 

New Execution Mode and Data Types 

Beginning with version 8.0, Agilent VEE supports two new data types - Int64 and Boolean and a new Execution 
Mode - VEE 8.  

Although the user can use TRUE and FALSE as constants since version 5.0, TRUE and False are not real 
Boolean constants. They are of Int32 type. From Agilent VEE 8.0, the two constants will be of real Boolean type. 
The supported logical operations in Agilent VEE 8.0 are AND, OR, NOT, XOR, ==, and  !=. Agilent VEE 8.0 also 
supports Boolean in Compiled Functions. The user can use VEE_BOOL as the return type and the parameter 
type of a Complied Function. VEE_BOOL is treated as Boolean. See Boolean for more information. 

New menu items and built-in functions added for Boolean: 

 Data => Constant => Boolean 

 Data => Constant => Boolean Array 

 Data => Alloc Array => Boolean 

 asBoolean(x) 

Int64 has the longest precision for representing an integer. Agilent VEE provides two built-in numeric constants to 
represent the maximum and minimum values of int64: MaxInt64 and MinInt64. Constants in different Execution 
Modes will be explained as different types. See Int64 for more information. 

New menu items and built-in functions added for Int64: 
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 Data => Constant => Int64 

 Data => Constant => Int64 Array 

 Data => Alloc Array => Int64 

 asInt64(x) 

Standardize on VISA Style Devices  

Phase out older inconsistent I/O devices (mixed SICL & VISA) for a more uniform approach (VISA) when 
declaring/using I/O devices. Backward compatibility is maintained, even though users are "encouraged" to use 
new-style devices. See here for detail information. 

Display Multiple Traces on Graph Objects through a Single Input Pin 

This feature allows the user to display multiple traces (an array of traces) with the Agilent VEE Graph objects 
without knowing how many traces there will be ahead of time.  

A new Boolean Graph property is added called 'MatrixInput' in detail view properties. When this MatrixInput 
property is set to True, the Agilent VEE Graph object would accept a 2D Array (up to 12 rows) as Input data and 
display multiple traces simultaneously. The Data container comes into a graph on a single input pin. The graph 
figures how many traces are contained there (up to 12 rows), shows the appropriate number of trace legends, and 
plots their points (columns). This new property CANNOT be toggled at runtime programmatically. The user must 
know when they are building their Agilent VEE program whether they need this new-style graph.  

For detail information, please see example program 2dXyTrace.vee, MatrixInputStripChart.vee.  

Multiple Transaction Enhancements  

In Agilent VEE 8.0, rich new features have been added for all transaction-based objects (e.g., Direct I/O objects, 
To/From objects), especially supporting operations on multiple transactions. 

Major enhancements include: 

* Arbitrarily select, delete, copy, and paste multiple transactions 

 

* Undo/Redo Add/ Insert/ Delete/ Cut/ Paste/ Edit/ Move up/ Move down actions 

* All Windows-standard shortcuts 
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CTRL+X --- Cut the selected transaction(s) to the "cut-and-paste" buffer  

CTRL+C --- Copy the selected transaction(s) to the "cut-and-paste" buffer  

CTRL+V --- Paste transaction(s) at the pointer location  

Delete  --- Delete the selected item(s) in the list  

Insert  --- Insert a transaction before current selected item  

CTRL+Z --- Undo last operation  

CTRL+Y --- Redo last operation  

CTRL+Up --- Move the selected transaction up (only for single-transaction) 

CTRL+Down --- Move the selected transaction down (only for single-transaction) 

CTRL+ LeftButtons --- Select multiple transactions 

Record Usability Enhancement 

Agilent VEE 8.0 enhances Record usability in three aspects: 

1. Declare Variable now has a Generate context menu for Record data type. The user can generate Record 
Constant objects, Build Record objects, and Unbuild Record objects. 

 

2. Record Constant object now has a new Generate context menu for Record data type. The user can generate 
Declare Variable objects or Unbuild Record objects. 
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3. Added a new Built-in Function: buildRecord (fieldNameTextArray, field1, field2, fieldN) 

The user can use buildRecord() to build a record whose field names and values are not known until runtime. The 
first parameter is an array of strings for the field names. The following parameters are values for each field, and 
the number of these parameters must match that array length. buildRecord() returns a scalar record with the 
specified field names and field values. Two examples are as follows: 

buildRecord(fieldNameList2Long, field1, field2);  

builldRecord(fieldNameList8Long, field1, field2, field3... field8); 

See buildRecord() for more information. 

NIDAQ Support Updated to Include NIDAQmx Drivers  

Agilent VEE 8.0 provides support for new NI's Data Acquisition driver library NIDAQmx. This support includes 
access to all of the functions in the library and online help for each function. Instruments Manager can find 
instruments with NIDAQmx drivers automatically.  

Allow Scrolling in Panel View  

ScrollBars can be set to automatically appear when your panel view is not large enough to display all 
objects. This feature can be turned on and off by changing the Panel property named "ScrollbarsEnabled". The 
default is off. See here for detail information. 

Instrument Samples  

Added 16 new instrument samples in examples\instrumentIO\InstrumentManagerIntegrated.  

Updated many Instrument samples.  

See Also   

New Features and Enhancements in Past VEE Versions, What's Been Fixed in this Release 
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What has been Fixed in Version 8.0 

ID Descriptions Broken 
in 

27961 VSE: Junction object passes NULL when it should not have fired.  If it had inferred as 
non-nil, VSE in downstream expression. 

7.52 

28140 VEE applications will enter to infinite loop if DropDownList items are changed. 7.52 
28234 VSE when deleting instruments in Instrument Manager. 7.52 
28141 Disabled DropDownLists can be controlled by users. 7.52 
27672 VSE:savePanelImage throws a VSE  when the input parameter number is not 3. 7.52 
28508 Sample Code Error: Able to detect unplugged device.  7.52 
28110 Cannot load UFs which are named in Japanese Character. 7.52 
28362 VSE when double clicking on the control input pin - "scales" of XYTrace objects. 7.52 
27997 In the dynamic IO Active X control - the USB interface appears as unknown. 7.52 
28118 VEE should automatically call Dispose on .NET objects when programs stop. 7.52 
28479 Examples: Games\Starveego\network's outputs mismatch. 7.52 
28225 Pops up error 401 when creating event handler for .NET controls. 7.52 
28278 Vee HANG when editing text array. 7.52 
28130 Cannot use escape character in strings in .NET operation builder. 7.52 
28151 Multiple selecting and deleting Record Field Data causes vee to hang 7.52 
28107 Cannot get right and full file name by using GetFile(path) in system menu in japanese 

OS. 
7.52 

27776 USB instruments time out after x number of runs. 7.52 
27871 NI DAQ driver won't import into Toolkit Driver Session wizard. 7.52 
27811 Infinite Loop during opening a file with embedded IO. 7.52 
28087 Text in the list box gets reformated when moving the box. 7.52 
28285 Duplicate variables appear on Program Explorer. 7.52 
28235 Pops up "unexpected error" when clicking "Abort" in "adding instrument" dialog box. 7.52 
28204 Changing the address of an Instrument via formula to 0 does not make it act "live 

mode off". 
7.52 

28187 Should not generate terminal names automatically as Result. 7.52 
28295 VSE when we work with Coord data type in the record constant. 7.52 
28155 Concatenator fail to combine two or more different int type constants. 7.52 
27702 VEE online help->Welcome->Example Programs->missing instrument samples. 7.52 
28089 No prompt when closing VEE after changing type of Declared variables. 7.52 
28311 DExplore still live after VEE exits. 7.52 
28049 Annoying behavior of "Declare Variable" & Real64. 7.52 
28158 Input pins in the DateTime.Compare object do not match the formula. 7.52 
      
27665 VSE using NIDAQ SCAN_Start() functions that assume async / buffered data. 7.51 
28457 PageUp causes problems in FOB. 7.51 
28379 VSE when showPanel/hidePanel on RPC Functions or DLL Functions. 7.51 
27293 .NET Op Builder's type checking during editing needs to be relaxed.  7.51 
27179 COM type conversion doesn't utilize QueryInterface. 7.51 
27668 Error 514 "Numeric overflow in function Regression". 7.51 
27696 IVI-COM object becomes System.__ComObject after a number of iterations. 7.51 
27574 VEE fails to find IVI-COM driver automatically if driver prefix does not match 

SoftwareModuleName. 
7.51 

27135 NIDAQ: VEE doesn't handle overlapping, NIMAX-assigned device addresses... 7.51 
27438 Description Indicator cannot be cleared. 7.51 
27126 IVI-COM examples have extraneous instrument references. 7.51 
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27650 Interface duplicated when add USB or TCPIP instruments. 7.51 
      
28268 VSE: mod zero at iopath.m when reading text and the dimSizeBlock is zero. 7.5 
28200 Vee Caution appears when importing library that consists of .net form control. 7.5 
27635 NIDAQ objects don't copy/paste well. 7.5 
27674 Online Help for LockPosition refers to Lock Panel Position property which has been 

changed. 
7.5 

      
23402 Vxipnp & DllFunc do not truly support UInt8 (gets converted to Int16 coming back out). 7.0 
23296 DynamicFindRemoteInstruments.vee finds only devices connected to GPIB interface, 

not LAN interface. 
7.0 

28333 VSE Print program when device name is longer than 200 at contextView.m. 7.0 
27684 VSE when a VEE popup panel has focus, a .NET Dialog pops up, and program stops - 

kbdFocusView = freed id from popupPanel 
7.0 

27990 VSE on exit of VEE with selected XY trace on panel when XY trace is added to panel 
after XY is executed. 

7.0 

27889 VSE de-selecting an object that errored during selection, eg a Picture object pointing to 
an illegal bmp / jpg.  

7.0 

27571 Changes made to your I/O config via ACE will not be seen by VEE until you exit/restsrt 
VEE. 

7.0 

28421 Vee display improper IO error message. 7.0 
26948 .NET changes the behaviour of VEE floating point error handling. 7.0 
28378 Lack of SRQ (RQS) for TCPIP and USB instruments. 7.0 
27770 Undo of Cut of a UO without its parent Context visible shows wrong values in 

PropGrid. 
7.0 

23994 Problems when attempting to edit Value Constraint Field on Real64 Input and Int32 
Input objects. 

7.0 

27656 VSE loading corrupt save file 'Cannot create views for component' parsing 
viewFor/devCarrierFor dd with no NPort devId 'dd'. 

7.0 

28079 Double-clicking on an iconized PCall that is in a UO (not in a UF) writes a minidump 
file. 

7.0 

      
28030 Duplicated type(int16) in Record field attributes. 6.2 
      
28097 VSE when GPIB gateway hostname is longer than 32 characters in vee.io file. 6.0 
27998 Clicking on the Call user function object in one lib jumps to the wrong lib. 6.0 
27494 VSE right button context menu on an object on a runtime popup panel can send 

MENUPICKEVENT after that object is free. 
6.0 

27596 Logical Or of UInt8 data array gives wrong answer (sometimes!). 6.0 
27463 File->Create Runtime Version should be greyed out when program is running or 

paused. 
6.0 

      
27838 VSE on UserObject -> "Make UserFunction" when UO name isValidName: true but is 

duplicate name in NameSpace. 
5.0 

27687 VSE Internal 'compareValues not defined for this type' on sort() on rec of rec of array. 5.0 
27729 VSE PopupPanel does not recognize selectList when F1 is pressed with a PopupPanel 

up in Pause state. 
5.0 

      
27799 VSE on interactive delete of a UO with a sub-UO with a Global-Scope DeclVar in it. 4.0 
27683 VSE on veerun exit, freeing UO with sub-UO with DeclVar global scope. 4.0 
28411 Memory leak in file IODevCreate.m. 4.0 
      
27544 Veesm will not connect if hostname starts with a number not a letter. 3.0 
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VSE: VEE Serious Error 

27573 Sequencer variable "thisTest" not available in EnabledIf expression (documentation 
says it is), unless, you open and Ok trans. 

3.0 

27608 VSE on Raise Error with error code 950-999.  Should give little error "don't do this" not 
VSE 

3.0 
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