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About This Manual
This manual is a quick start introduction to graphical programming with 
HP VEE. No previous knowledge of HP VEE, or of graphical programming, 
is necessary. However, you should be familiar with your computer and its 
operating system.

Note Using this manual assumes you have installed HP VEE. If you have not 
done this, follow the instructions in the documentation that came with your 
installation media.

This manual has two chapters and an abbreviated glossary.

Chapter 1, “Quick Start” takes you through hands-on exercises that sho
you how to work with HP VEE and create HP VEE programs. To learn h
to use HP VEE, follow along, doing the exercises on your computer. Stop
a break at any time.

Chapter 2, “Some HP VEE Programming Techniques” illustrates selecte
HP VEE programming techniques such as mathematically processing d
and performing instrument I/O.

The Glossary describes major terms used in this manual. It does not co
all terms related to HP VEE.
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Conventions Used in This Manual
This manual uses the following typographical conventions:

Getting Started Italicized text is used for book titles and for 
emphasis.

Dialog Box Bold text is used for the first instance of a word 
that is defined in the glossary.

File Computer font represents text that you will see 
on the screen, including menu names, features, 
buttons, or text that you have to enter.

dir filename In this context, the text in computer font 
represents an argument that you type exactly as 
shown, and the italicized text represents an 
argument that you must replace with an actual 
value.

File ⇒ Open The “⇒” is used in a shorthand notation to show 
the location of HP VEE features in the menu. For
example, “File ⇒ Open” means to select the 
File menu and then select Open.

Sml | Med | Lrg Choices in computer font, separated with bars 
(|), indicate that you should choose one of the 
options.

Press Enter In this context, bold represents a key to press on
the keyboard.

Press Ctrl + O Represents a combination of keys on the 
keyboard that you should press at the same time
 v
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Quick Start

HP VEE is Hewlett-Packard’s Visual Engineering Environment, a graphical 
programming language for creating test systems and solving engineerin
problems. 

HP VEE has two parts; namely, a development environment that lets you
all HP VEE features and a run-time environment that lets you run HP VE
programs that were created via the development environment. Both 
environments ship on the media you received for installing HP VEE.

During installation, an initial screen might have given you a choice; nam
to install the run-time environment or install the development environme
To work through this manual, you must have installed the development 
environment. If you did not do this, repeat the installation to install the 
development environment. Do not also install the run-time environment (it is
automatically included with the development environment).

How to install the run-time environment (which you need not do until yo
run HP VEE programs on PCs that do not have HP VEE) is discussed in
HP VEE online help. To get the information, select Help and then select 
Contents and Index. Then, double-click on Installing and 
Distributing HP VEE RunTime. If desired, you can print the 
information.

This chapter takes you through some simple exercises to help you beco
familiar with using the HP VEE graphical programming language. Also, 
you’ll learn some key HP VEE concepts and create some simple HP VE
programs.
2 Chapter 1 
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Interacting with HP VEE 
This section explains how to use the HP VEE graphical programming 
language; for example, it explains how to manipulate objects, create 
programs, save files, and print screens. A good procedure is to work through 
the book, doing the exercises on your computer.

The Mouse and the Menus

You’re probably familiar with your computer’s mouse- and menu-driven 
interface; the pull-down menus, toolbars, and dialog boxes that you con
with the mouse and keyboard. HP VEE uses your computer’s interface. 
you need help in this regard, the documentation that came with your 
computer and its operating system includes information about topics suc

n Choosing commands on the menu bar.
n Selecting and dismissing menu items.
n Using toolbars.
n Understanding title bars and status bars.
n Clicking on icons and buttons.
n Working with dialog boxes.
n Working with various types of windows.
n Using online help.

To get help on these topics, refer to the documents and online help for y
system.

Supported Systems

HP VEE is supported on the following systems:

n Windows 95 on a PC.
n Windows NT Version 4.0 on a PC.
n HP-UX Workstation (Versions 9.x, 10.01, and 10.2 on Series 700). 

HP VEE does not run on Version 10.0 or 11.x.
Chapter 1 3
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Mouse Techniques

At times, you get instructions about using the mouse to operate menus, 
icons, buttons, and objects. Here are the common techniques:

n When we say to “click on” an item, you should place the mouse poin
on the desired item and quickly press and release the left mouse button. 

n When we say to “double-click”, you should place the mouse pointer o
the desired item and click the left mouse button twice, in rapid 
succession. 

n When we say to “drag”, place the mouse pointer on a desired item, hold 
the left mouse button down, and move the item to the appropriate 
location. Then, release the button. 

The right mouse button is used less frequently, and only for special 
purposes. If you are to click the right mouse button, we’ll say so. If your 
mouse has a middle button, you will not use it for HP VEE.

Starting HP VEE

Windows 95 or 
Windows NT

Click the Start button, then point to
Programs ⇒ HP VEE 5.0, and click on HP VEE.

HP-UX From a shell prompt in an HP VUE or X11 window, type: 
veetest Return. 
(The PATH variable must include /usr/bin.)
4 Chapter 1 
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The HP VEE Window

The following figure shows the HP VEE window. Your window might vary 
slightly.
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For the previous figure, the following items describe the parts of the 
HP VEE window.

Title bar The top line in the window contains the HP VEE icon, the 
window name, and the minimize, maximize, and close buttons. 
Move the window by dragging the title bar. Click on the 
HP VEE icon to get the window’s menu.

Menu bar The second line contains menu items, each of which provides
HP VEE commands or objects. 

Toolbar The third line contains icons that provide direct access to 
commonly used menu commands.

Work space A region in the HP VEE window that contains edit windows 
such as Main, UserObject, or UserFunction.

Work area A region in a programming (edit) window such as Main, 
UserOjbect, or UserFunction in which you place objects 
and wire them together. 

Program 
Explorer

A region on the left side of the HP VEE window showing the 
structure of your HP VEE program. The upper corner shows t
current program’s name, such as myprog.vee; or it displays 
Untitled. The Program Explorer lets you move among you
programming windows. To resize the Program Explorer, move
the normal pointer on the right boundary until it changes to a 
vertical splitter. Then click, and move the splitter to resize the
Program Explorer.

Main window A window in the work space that contains a work area in whic
you develop and edit HP VEE programs. There can be other 
programming/editing windows; for example, UserObject.

Status bar The bottom line displays messages about HP VEE’s status, 
including four status indicators in the right corner. The 
indicators (from right to left) show:
n The compatibility mode.
n The state of the profiler.
n Mod appears when the program has been modified.
n Web server is enabled.
6 Chapter 1 
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Quitting HP VEE

The following items offer suggestions for quitting HP VEE and continuing 
to work through this document.

n Provided a program is not running, you can quit HP VEE at any time via 
the usual windows operations (for example, clicking on the X button at 
the right end of the title bar).

n Before you quit, you may want to save the contents of the windows in 
your work space. (The “Save Your Program” section, later in this 
chapter, explains how.)

n While doing the exercises in this chapter, you can save your file and 
whenever you want to take a break.

n You can restart HP VEE later, open your file, and continue where you
left off. (The “Open a File” section, later in this chapter, explains how

Working with Objects

An HP VEE program consists of connected objects:

n You select objects from HP VEE’s menus; for example, Flow, Data, and 
Display.

n You connect the objects via lines that attach to the objects’ pins (mor
pins later).

n A group of objects and how they are connected makes up a program

Let’s begin by learning how to use objects to create a program.
Chapter 1 7
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To Add Objects to 
the Work Area 

Pull down an appropriate menu, click on the desired object, drag the object 
to an appropriate location in the work area, and click (the outline will 
disappear and the object will appear). 

For example, to select the Function Generator object, click on Device 
in the menu bar. Then, click on Virtual Source in the Device menu. An 
additional menu of virtual source objects appears, as shown in the following 
figure.

To add the Function Generator to the work area click on it. An outline 
of the object appears in the work area. Move the outline to where you want 
the Function Generator and click the mouse button. The next figure 
shows this.
8 Chapter 1 
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Having placed an object in the work area, you can move it by dragging its 
title bar, just as you move a window.

Note Hereafter, a shorthand notation is used to explain how to select an object. 
For example, selecting the Function Generator object is expressed as:

Device ⇒ Virtual Source ⇒ Function Generator 
Chapter 1 9
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To Change Object 
Views

Every HP VEE object has at least two views — an open view and an icon 
view. The two views of the Function Generator object are shown below:

By default, the Function Generator object appears in its open view. You
will see, later, that some objects appear initially in their icon views.

You can always change the view. Click once on the object’s open view 
minimize button to get the icon view, and double click on the object’s ico
view to get the open view. Using the icon view helps you save space in 
work area. In the open view, all parts of the Function Generator object 
are visible, and you can edit them. 

n The object menu button, title area, and minimize button appear at the
of the object.

n The input terminal and output terminal areas appear on the left and r
sides.

n The parameters associated with the Function Generator object 
appear in the middle. 

As you will see, not all objects have the same structure or parts, but you
edit objects in their open views and save space in their icon views.
10 Chapter 1 
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To Select an Object 
Menu

Each HP VEE object has an object menu that lets you perform actions on 
the object; for example, Clone, Size, Cut, Move, and Minimize. Most 
objects have similar attributes, but there are differences, depending on the 
functionality of the object. You can get online help for the specific object 
from the object menu.

To select the popup object menu, click once on the object menu button. The 
object menu appears, as shown below. (Don’t double-click on the objec
menu button — that’s a shortcut for deleting the object.)

Now you can click on one of the object menu choices to perform the act
you desire. Or, to dismiss the object, click on an empty area outside the 
menu.

Note As a shortcut, you can also select the object menu by placing the mous
pointer anywhere on the object body and clicking the right mouse button. 
This works for the open and icon views.

To Move an Object To move the Function Generator object, click on Move in the object 
menu, then click and hold the left mouse button. An outline of the objec
appears. Move the outline to the new location while continuing to hold th
mouse button down, as shown in the following figure.
Chapter 1 11
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Release the mouse button — the object jumps to the new location.

Note As a shortcut, you can also move an object as follows:

Click on the title area of the open view of an object and drag the object t
new location.

Except for buttons, entry fields, pins, terminals, or the bottom right corne
(which resizes the object), click on any part of an open view object and d
the object to a new location.

Click on any part of an icon view object except the bottom right corner 
(which resizes it) and drag the icon to a new location.
12 Chapter 1 
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Note “Object Location Information”, located on the status bar, at the bottom of
work space, gives the X and Y position, in pixels, of the upper-left corne
the outline relative to the upper-left corner of the work space. Use this 
information when you need to place an object in an exact position.

To Clone (Duplicate) 
an Object

To clone the Function Generator object, get into the object menu and 
click on Clone. An outline of the object appears. Move the outline to the
desired location.

Now click the mouse button and the cloned object appears, while the 
original object remains.

To Delete an Object To delete an object from the work area, get into the object menu for the 
object you want to delete and click on Cut. For example, get into the object
menu for the Function Generator on the right and click on Cut. The 
object disappears from the work area, but it is saved in the cut buffer. 
Chapter 1 13
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To paste a deleted (cut) object back into the work area, click the Paste 
button on the toolbar, or use Edit ⇒ Paste. The object’s outline appears. 
Move the outline to the desired location and click the mouse button.

Note As a shortcut, you can also delete an object by double-clicking on its object 
menu button. Be careful, this is easy to do by accident. If you do delete 
object by accident, use the Paste toolbar button (or Edit ⇒ Paste) to 
recover the object and all connections to it.

To Change the Size 
of an Object

To change the size of an object, get into the object menu and click on Size. 
The mouse pointer becomes a “bottom-right-corner” bracket. Move this 
bracket to define the size that you want, as shown below:
14 Chapter 1 
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Then, click the mouse button again, and the object is resized.

Try resizing the object a few times on your own. You can enlarge the object 
or reduce it as much as you want.

Note As a shortcut, you can also resize an object (either the open view or icon) by 
dragging on its bottom right corner.

To Change the Title 
of an Object

To change the title, get into the object menu and click on Properties. A 
dialog box appears in which you can edit the object’s title.

Just start typing to enter the new title. The old title is replaced automatic
When you click on OK, the new title appears in the title area. If you minimiz
the object, the new title appears in the icon.

You can save time by using standard keyboard and mouse editing 
techniques. For example, if you click at the extreme left edge of the edit
Chapter 1 15
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area, the cursor will appear there. You can then add new text without 
deleting the existing title.

Note As a shortcut, you can change the title of an object by double-clicking on the 
title in the current object’s open view. The Properties dialog box appears. 
Type in the new title and press Enter.

For more information, select Help ⇒ Contents and Index from the 
HP VEE menu bar. Then, browse How Do I..., Tell Me About..., or 
Reference.

To Clear the Work 
Area

You have some options for clearing the work area.

n Use Edit ⇒ Select All and then click on the Cut button on the 
toolbar. This deletes (or cuts to the cut buffer) all objects in the active
window and you can begin programming anew in that window. Later,
you want a new work area, HP VEE will ask if you want to save chan

n Click the New button on the toolbar, or use File ⇒ New. HP VEE asks if 
you want to save changes.

n You can clear individual objects by clicking on an object to make it 
current and then clicking on the Cut button on the toolbar. This lets you
clear any of several objects.

You might want to practice clearing the work area, using the above meth
When HP VEE asks about saving changes, click on No (unless you want to 
save them, of course).

To Manage the Work 
Space

So far, most discussion focused on the work area in the Main window. In
larger context, HP VEE contains a work space that contains your windo
You can manage these windows.

Each window has an icon (which provides menu commands), a title, and
three buttons; minimize, maximize, and close. Maximizing a window mak
it occupy the entire HP VEE work space. Minimizing a window makes its
icon appear along the bottom of the HP VEE work space. Closing a wind
removes it from the work space, but you can retrieve it by clicking on its
16 Chapter 1 
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entity in the Program Explorer. (By the way, the Program Explorer appears 
in the HP VEE window when it is checked in the View menu. If you remove 
the check, and click the Save button in File ⇒ Default Preferences, 
the Program Explorer will not appear the next time you start HP VEE. The 
default is for it to appear.)

The following figure illustrates a situation for having windows in the work 
space.
Chapter 1 17
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To Select the Edit 
Menu

There are several contexts for edit menus.

n HP VEE provides a generic edit menu in the menu bar. Those commands 
are the same for all of HP VEE.

n The HP VEE toolbar contains often-used editing commands; for 
example, Cut, Copy, and Paste.

n Each object has a menu for editing (the object’s object menu). This m
can vary among objects.

You can select the common Edit menu in either of two ways. If you select
Edit from the menu bar, the Edit menu appears, as shown next.

Or, you can select the common Edit menu by clicking the right mouse 
button in any blank area of the work space. In either case, click the left 
mouse button anywhere outside the menu to dismiss it.
18 Chapter 1 
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Note Edit menu selections such as Cut, Copy, Clone, remain inactive (“grayed 
out”) until at least one object has been selected. You’ll see how this work
the next section. (The selection Edit UserFunction... is also inactive 
unless UserFunctions are present.)

To Cut and Paste 
Objects

The Edit menu lets you cut and paste objects. For example, add a Formula 
object to the work area by selecting Device ⇒ Formula. Place the object 
in a convenient place as shown next.

The shadow around the object indicates that the Formula object is selected. 
You can remove a selected object by selecting Edit ⇒ Cut, or by clicking 
on the Cut button on the toolbar. (The Cut command becomes active when
you select the object. It is inactive until at least one object is selected.) 

Now paste the object back into the Main window. Use Edit ⇒ Paste or 
click the Paste button on the toolbar. Move the outline to the desired 
Chapter 1 19
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location and click the mouse to paste the Formula object. When an object is 
in the cut buffer, you can paste it as many times as you want.

Note Whenever you cut an object (either from the Edit menu, the object menu, or 
the toolbar), the object is removed from the work space, but it is saved in the 
cut buffer. However, only the most recently cut object is saved in this buffer.

To Copy or Clone 
Objects

The Copy command copies the selected object into the cut buffer. Then, you 
can Paste the object in desired locations. The Clone command clones the 
selected object directly, and you can then drag the object to a desired 
location.

To try this for Copy, click on the Formula object to select it. Then, use 
Edit ⇒ Copy (or click on the Copy button). Now, click on the Paste 
button on the toolbar (or use Edit ⇒ Paste). Move the object outline to the 
desired location and click. You can repeat the Paste operation as desired. 
The copy-paste operations deselect the copied and pasted objects (no 
shadowed objects).

To try this for Clone, click on the Formula object to select it. Then, click 
on the object with the right mouse button to obtain the object menu. Select 
Clone, move the object outline to the desired location, and click. The clone 
operation leaves the original object selected (shadowed). This is shown 
below.
20 Chapter 1 
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To Select Multiple 
Objects

The easiest way to select an object is to click on it, but this selects only one 
object. When you select a another object, the previous one is deselected (its 
shadow disappears).

To select all objects, use Edit ⇒ Select All. All objects become 
shadowed. Clicking the left mouse button in an empty part of the work area 
deselects all selected objects. 

You can select certain objects by pressing and holding Ctrl, and then 
clicking on each object you want to select. (Ctrl+left mouse button.) The 
selected objects become shadowed. The following figure shows selected and 
deselected objects.
Chapter 1 21
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To Copy Multiple 
Objects

There are two methods for copying several, selected objects.

n Copy the selected objects by placing the cursor on an object. Press and 
hold Ctrl while using the left mouse button to drag the multiple objects 
(outlines) to a desired location.

n Or, use Edit ⇒ Copy to copy the selected objects to the cut buffer. Click 
on Paste (in the Edit menu or on the toolbar), move the objects 
(outlines) to a desired location, and click the left mouse button. 

The following figure shows this.
22 Chapter 1 
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Try experimenting with these commands on your own.

Note In HP VEE for Windows, objects that you cut or copy, are also placed on the 
Clipboard. You can paste them into other Windows applications that support 
the Windows Clipboard.

To Move the Work 
Area

Besides moving objects, you can move the entire work area. 

n One way is to click on an empty area and drag the work area in any 
desired direction.

n If your program size (collection of objects) exceeds the size of the visible 
work area, the window will have one or more scroll bars (vertical and/or 
horizontal). To “move” the work area, use the scroll bar (or bars).
Chapter 1 23
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Using the first method, click on an empty area, drag the work area so that 
objects are outside both the vertical and horizontal boundaries, and click. 
Note the scroll bars. (If you click near a terminal, a line or “wire” may 
appear. If this happens, move the pointer to an open area and double-c
The next figure shows this.

In the previous example, when you released the mouse button, the scrol
and scroll arrows shown in the figure appeared. As a reminder, you use
usual windows methods to reposition the visible work area.

To Change Default 
Preferences

To change the default settings in your HP VEE environment, click the 
Default Preferences button on the toolbar, or use File ⇒ Default 
Preferences. The Default Preferences dialog box appears.
24 Chapter 1 
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This dialog box has tabs that let you select options to edit.

For more information, select Help ⇒ Contents and Index from the 
HP VEE menu bar. Then, browse How Do I..., Tell Me About..., or 
Reference.

General The default tab when the Default Preferences 
dialog box appears (shown previously). You can change 
the values of the displayed parameters; for example, 
Environment and Compatibility Mode.

Colors Lets you customize the colors in your HP VEE 
environment.

Fonts Lets you customize the fonts in your HP VEE 
environment.

Number Lets you change the default number format.

Printing Lets you set the values of the parameters for your printer.

Web Server Lets you enable the built-in Web server to monitor and 
troubleshoot a program from a remote Web browser.
Chapter 1 25
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Understanding Pins and Terminals

An HP VEE program is the objects in the work area and the lines that 
connect them. The lines connect HP VEE objects at points that are called 
pins. The Note Pad object has no pins; otherwise, objects have one or more 
of the following types of pins.

In an object’s open view, the data input and output pins can appear as i
and output terminals. This way, the pins display their terminal labels. The
terminal labels are visible only in the open view, and only if the Show 
Terminals option is turned on for that object (see Properties... in the 
object’s menu).

Let’s look at an example. Add a Formula object to the work area (Device 
⇒ Formula). By default, the Formula object shows its terminals (the left-
hand item in the next figure).

Data Input Pin The pin (or pins) on the left-hand side of an object.

Data Output Pin The pin (or pins) on the right-hand side of an object. 

Sequence Input Pin The pin on the top of an object.

Sequence Output Pin The pin on the bottom of an object.
26 Chapter 1 
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If you turn off Show Terminals, the Formula object does not show its 
terminals (the right-hand item in the figure above). 

To turn Show Terminals ON or OFF, select Properties from the object 
menu. The properties dialog box displays a checkbox in front of Show 
Terminals.

Click on the checkbox, if checked, to turn Show Terminals OFF. Click on 
the checkbox again to turn Show Terminals back on. Click on OK after 
you have made your selection.

For more information, select Help ⇒ Contents and Index from the 
HP VEE menu bar. Then, browse How Do I..., Tell Me About..., or 
Reference.
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To Add a Terminal You can add a second data input terminal to the Formula object. In the 
object menu, select Add Terminal ⇒ Data Input. Or, provided Show 
Terminals is active, you can place the mouse pointer in the “terminal ar
(the left margin of the open view object) and press Ctrl+A (press the Ctrl and 
A keys simultaneously). In either case, a second data input terminal, B, 
appears as shown below.

To Obtain Terminal 
Information

To obtain information about a terminal, double-click on the label area. F
example, double-clicking on B makes the following dialog box appear.
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You can now edit the terminal. The dialog box has three kinds of fields:

If you select a data type other than Any for a data input terminal, only the 
specified type of data, or data that can be converted to that type, will be 
accepted by the terminal. Most of the time it is best to leave the Required 
Type and Required Shape fields set to Any. For more information, select 
Help ⇒ Contents and Index from the HP VEE menu bar. Then, 
browse How Do I..., Tell Me About..., or Reference.

entry field A field with a white background, but no arrow. It becomes a 
type-in field when you click on it. For example, you can 
click on B in the Name field and rename the terminal; for 
example, Base.

status field A field with a gray background that cannot be edited. For 
example, the Mode field cannot be edited.

selection field A field with a white background that has an arrow on its 
right-hand side. Clicking on the field or its arrow displays a 
drop-down list. For example, if you click on Any (or the 
arrow) in the Required Type field, you can select 
another data type from the list by clicking on it. The 
following figure shows this.
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To Delete a Terminal To delete a terminal (input or output), you can use the object menu:

(As a shortcut, you can place the mouse pointer over the terminal you want 
to delete and press Ctrl+D.)

Getting Help

HP VEE uses an online help viewer that is designed for your operating 
system. Click on Help and the following menu appears.

Select Contents and Index to start HP VEE Help as shown in the next 
figure. (The UNIX screens are slightly different.)

Input Terminal Select Delete Terminal ⇒ Input.

Output Terminal Select Delete Terminal ⇒ Output.
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The help window is hypertext driven. The Contents tab contains the 
following topics.

Note As a shortcut to get help on a selected object and on dialog boxes, press F1.

What’s New in HP VEE Explains new features. 

How Do I... Provides “how to” information.

Tell Me About... Explains concepts.

Guide to HP VEE 
Example Programs

Summarizes the example programs shipped 
with HP VEE.

Reference Provides reference information.

About HP VEE Support Explains getting support.

Installing and 
Distributing HP VEE 
RunTime

Installs an environment for running HP VEE 
programs, and explains how to distribute 
your programs.
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Programming with HP VEE
Having learned to work with objects and the HP VEE user interface, this 
section shows you how to connect objects to create HP VEE programs. You 
will also see how HP VEE graphical programs work.

A Simple Program

You create an HP VEE program, print the HP VEE screen, and save the 
program to a file.

To Create a Simple 
Program

An HP VEE program consists of HP VEE objects that you connect to from 
an executable object diagram. Let’s create a very simple program that 
displays a waveform. (If HP VEE is running, clear the work space by 
clicking the New button on the toolbar, or use File ⇒ New. Otherwise, start 
HP VEE and continue.)

Add the Function Generator object (Device ⇒ Virtual Source ⇒ 
Function Generator) and the Waveform (Time) object (Display ⇒ 
Waveform (Time)) to the work area as shown in the following figure.
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In the previous figure, the Func label on the Function Generator object 
denotes a data output pin, and the Trace1 label on the Waveform(Time) 
object denotes a data input pin. In HP VEE programming, you connect 
such pins to connect objects; and this determines the flow of execution of 
your program.

Complete the program by connecting the data output pin on the Function 
Generator (next to Func on the right side) to the data input pin on the 
Waveform (Time) display (next to Trace1 on the left side). To do the 
connecting, move the cursor to one of the pins. The cursor shape changes 
when it is near a pin where a connection is allowed. Click the left mouse 
button, move the mouse cursor to the other pin, and click again. A line is 
automatically routed between the two pins, and your program is complete.

Try moving one of the objects by dragging on its title bar. (Don’t drag on
pin or terminal — a line will appear if you do.) Note that the line 
automatically reroutes to the logical path between the two objects. The 
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routing works best when you construct an HP VEE program according to 
accepted programming practices.

Note If your lines appear to be scrambled, use Edit ⇒ Clean Up Lines to 
reroute the lines in your program.

To Run Your 
Program

To run your program, click the Run button on the toolbar, or use Debug ⇒ 
Run. The program displays a 200 Hz Cosine wave in the Waveform 
(Time) display, as shown in the next figure. (Your object might have a 
different frequency, which is not important to the example.)

In addition to the Run button, you can use the Stop, Pause, and Step 
buttons to control the program. If you pause a running program, use the 
Resume button to resume. You can use the Step button to run a program 
one-object-at-a-time.
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Note From now on, when we say to “run” your program, just click on the Run 
button on the toolbar, or press Ctrl+G. Accelerator keys for other program 
control buttons are:

Pause Ctrl+P

Resume Ctrl+G

Step Into Ctrl+T 

To Change Object 
Parameters

You can change the parameters of an object in its open view. You may h
noticed that the Function Generator object has two kinds of fields. A 
field with an arrow on its right-hand side is a selection field. For example
click on Cosine (or the arrow) in the Function field. A drop-down list of 
selections appears.

Click on Sine to select the Sine function as shown in the following figure
noticing that the Function field has changed from Cosine to Sine.
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Other fields have no arrows. These are entry fields, which become type-in 
fields when you click on them. Just click on a field and a cursor appears. 
You can use standard keyboard and mouse editing techniques to move the 
cursor and enter a desired value.

For example, click on the Frequency field to the right of the value 200 and, 
while holding the mouse button down, move the mouse to the left to 
highlight the last 0, then release the mouse button. The following figure 
shows this.
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Now, press Delete to delete the last 0, changing the Frequency value to 20. 
Run the program (click the Run button) and you should get the following 
result.
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The displayed waveform is now a 20 Hz sine wave. Try changing a few 
object parameters on your own as follows:

1. Click on Deg (or the arrow) in the Function Generator object and 
change the phase units to Rad. Now click on the Phase value field and 
enter the value PI. Run the program and note the phase shift in the 
displayed waveform. Now change the Phase value back to 0 and the 
units back to Deg.

2. The y-axis limits of the Waveform (Time) object are preset to -1 
through 1. Click on the y-axis name Mag, to open a dialog that lets you 
change the settings. Click in the fields for Maximum and Minimum to 
change the limits to 2 and -2. You’ll see the waveform displayed within 
the new limits. To change similar parameters for the x-axis scale, click
Time.
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To Print the Screen To print the screen, select File ⇒ Print Screen.

For HP VEE for Windows, the following dialog box appears.

When you click on OK, HP VEE prints the screen on the default printer 
named in the dialog box. You can select another printer, change the print 
range, and enter the number of copies. Click on the Properties button for 
more selections. Different print drivers may use different dialog boxes. For 
further information about using Windows dialog boxes, refer to the 
Microsoft Windows Help.

For HP VEE for UNIX, the following dialog box appears.
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When you click on OK, HP VEE prints the screen on the selected printer. 
This dialog box lets you select a graphics printer or text printer. It also lets 
you change the configuration of these devices before you print.

As a shortcut, click the Print Screen button on the toolbar to print the 
screen directly. 

To Save Your 
Program

You can save your program at any time (whatever is in the work area, 
whether a complete program or not). Click the Save button on the toolbar, 
or use File ⇒ Save.

For HP VEE for Windows, the following dialog box appears.

By default, HP VEE for Windows saves your files in the VEE Programs 
folder. To save the current program, just type in a name in the File name 
field (for example, simple-program) and click on Save. HP VEE for 
Windows automatically adds the extension .vee to the file name, saving the 
program as a VEE Programs type.

Note In HP VEE for Windows, you can use the long file names allowed by 
Windows 95 and Windows NT.

For HP VEE for UNIX, the following dialog box appears.
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By default, HP VEE for UNIX saves your files to the directory from which 
you started HP VEE. To save the current program, just type in a name (for 
example, simple-program.vee) and click on OK.

Note To re-save your program to the same file name click the Save button or 
press Ctrl+S at any time (File ⇒ Save). It is a good idea to save your file 
frequently while you are developing a program. To save your changed 
program to a different file name, press Ctrl+W or File ⇒ Save As.

To Open a File You can open a program file by clicking the Open button on the toolbar or 
press Ctrl+O (File ⇒ Open). The Open File dialog box is essentially the 
same as the Save File dialog box, but you’ll be given a list of available 
files from which to choose. Just click on the desired file name (or type in
name in the File name field), and then click on Open (OK in UNIX) to 
open the file. 
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How HP VEE Programs Work

In conventional programming languages such as C, BASIC, or Pascal, the 
order in which program statements execute is determined by a set of 
sequence and selection rules. Generally, statements execute in their order of 
appearance in the program unless certain statements cause execution to 
branch to another statement or thread of code.

In HP VEE the general flow of execution through a program is called 
propagation. Propagation through a program is not determined by the 
geographic locations of the objects in the program, but rather by the way the 
objects are connected. Propagation is primarily determined by data flow, 
which is determined by how the data input and output pins of the objects are 
connected. Here are the rules of data flow:

n Data flows from left to right through an object. This means that on all 
objects with data pins, the left data pins are inputs and the right data pins 
are outputs.

n All of an object’s data input pins must be connected. Otherwise an error 
will occur when the program is run.

n An object will not execute until all of its data input pins have received
new data.

n An object finishes executing only after all connected and appropriate
data output pins have been activated.

In HP VEE you can change the order of execution by using sequence input 
and output pins. You do not normally need to use sequence pins, except to 
ensure the order of execution when controlling external devices such as 
instruments. For internal HP VEE operations, it is generally best to avoid 
using the sequence pins. If possible, let data flow control the execution of 
your program.

To see how data flow works, let’s take another look at the program you 
created earlier. Open the program (simple-program.vee) that you saved 
in the previous section (click the Open button on the toolbar) and run it. It 
should appear as follows, allowing that you might have some different 
values for parameters.
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Note that the data output pin of the Function Generator object is 
connected to the data input pin of the Waveform (Time) object. When you 
run the program, the Waveform (Time) object won’t execute until it 
receives data from the Function Generator object. This is a simple 
example of data flow.

Now let’s create a “noisy sine wave” by adding a Noise Generator object 
to our program, as shown below.

To create this program you first need to delete the line connecting the 
Function Generator and Waveform (Time) objects in the original 
program. You can use the Delete Line button on the toolbar to do this; 
click on the Delete Line button, and then click on the line. Or you can us
a shortcut; press and hold Shift+Ctrl and click on the line.
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Now proceed as follows:

1. Minimize the Function Generator to its icon.

2. Add the Noise Generator object (Device ⇒ Virtual Source ⇒ 
Noise Generator).

3. Add the A+B object. (Use Device ⇒ Function & Object Browser. 
Then, in the Function & Object Browser, for Type, select 
Operators. For Category, select Arithmetic. For Member, select 
+.) Then, minimize the A+B object.

4. Connect the input and output pins as shown in the previous figure.

5. Run the program.

Note that the Waveform (Time) object won’t execute until it has received
data from the A+B object. The A+B object won’t execute until both of its 
inputs have been satisfied by the Function Generator and Noise 
Generator objects. 

This leaves a question; namely, which object executes first, the Function 
Generator object or the Noise Generator object? The answer is that it 
doesn’t matter. The result is the same. The A+B object doesn’t execute until 
both generator objects execute. Once both of the A+B input data pins receive 
data, the A+B object executes, summing the two signals and outputting th
result to the Waveform (Time) object. Thus, the program operates just 
fine. The data flow determines the execution. 

To see the order of execution, turn on the Debug commands Show 
Execution Flow and Show Data Flow by clicking on their respective 
buttons on the toolbar. Now run the program. Each object highlights whe
executes, and a small, square marker moves down the lines to show da
flow.

Note Show Execution Flow and Show Data Flow can be enabled together o
individually by clicking on their toolbar buttons or on their commands in t
Debug menu. Normally, you’ll want to turn these commands off because
they slow down your program.
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Now, add an Amplitude input for the Noise Generator. Use the object 
menu, or just press Ctrl+A with the mouse pointer in the “terminal area” at
the left side of the Noise Generator. A dialog box asks you to select an 
input to add.

Select Amplitude by clicking on OK — an Amplitude input terminal 
appears. Now add a Real Slider object (Data ⇒ Continuous ⇒ Real 
Slider) and connect its data output pin to the Amplitude terminal, as 
shown in the following figure. Run the program.
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Try changing the amplitude of the noise (drag the slide control on the Real 
Slider object). The amplitude of the noise doesn’t change until you run 
program, and then the noise component of the displayed waveform dep
on the Real Slider output value.

Again, data flow determines the order of execution. The Noise 
Generator can’t execute until the Real Slider executes. The A+B object 
can’t execute until both the Function Generator and the Noise 
Generator execute, but it doesn’t matter which one executes first. Fina
the Waveform (Time) object executes only after the A+B object has 
executed.

Save your program again (to simple-program.vee). You’ll add some 
more features to it in the next chapter.
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HP VEE Programming Techniques

In the previous chapter you learned how to interact with HP VEE and create 
a simple HP VEE program. In this chapter, you will learn selected HP VEE 
programming techniques that you may find useful in building your own 
programs. These techniques include:

n Creating UserObject objects.

n Creating panel views.

n Using data files.

n Mathematically processing data.

n Communicating with instruments.
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General Techniques
This section provides general HP VEE programming techniques that include 
creating UserObject objects, creating a panel view, and using data files.

Creating a UserObject

A UserObject object (hereafter just called UserObject) is created by 
placing a logical and customized group of objects in the work area of a 
UserObject window. You wire the objects together as usual.

The objects in the UserObject window are associated with an icon view of 
the UserObject, which resides in the Main window.

You can define input and output pins for your UserObject and wire it to 
other objects in your program.

The idea, in developing a UserObject, is to create a unique context that 
performs a useful purpose within the context of the main program. Besides 
conserving real estate in your main work area, you can make your program 
more understandable by giving it structure.

Since you might create many user objects, and you might nest them, you 
should keep track of the icon views of the UserObjects, which reside in the 
main program, and their associated UserObject windows, in which you 
develop the user objects. One way to do this is to name the user objects in 
their edit windows, which also names them in their associated icon views.

One way to create a UserObject is to select Device ⇒ UserObject from 
the menu bar. An icon view of the UserObject appears in the Main 
window (work area). This icon view of the UserObject cannot be edited 
directly. To create the user object’s program, double click on the icon view of 
the UserObject. This calls (pops up) an associated UserObject window 
(work area), which is shown in the next figure.
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In this work area, you can add objects to the UserObject. After you 
develop your UserObject, you have options for the UserObject window 
as follows:

n Close the window by clicking on its close button.

n Maximize the window by clicking on its maximize button. If you do this, 
the UserObject window will occupy the entire HP VEE work space.

n Minimize the window by clicking on its minimize button. The minimized 
window will locate along the bottom of the HP VEE work space.

Regardless of what you do with the UserObject window, the icon view of 
the UserObject resides in the Main window, and you can connect its pins 
to other objects in that window.

Another way to create a UserObject is to select objects within a program, 
and then create a UserObject from them. 

Let’s use this alternate method, but, first, close the UserObject window 
you just created so that you have only the Main window.

To create the UserObject, use the program you created in the last chapter. 
Open the program (simple-program.vee). It should appear in the main 
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work area. Now, minimize the Noise Generator object, and rearrange the 
objects as shown in the next figure.

 

To make the UserObject, select the Noise Generator and A+B objects. 
To do this, use the shortcut; Ctrl+left mouse button. 

To create the UserObject from the selected objects, click on 
Edit ⇒ Create UserObject. The UserObject will contain the Noise 
Generator and A+B objects in the UserObject edit window, and will be 
automatically created in the Main window with the appropriate input and 
output pins and connections as shown in the next figure.
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Note Rearranging the positions of the objects before executing Create 
UserObject is one of convenience. If you don’t collect the objects to be 
included into one area, the UserObject will size itself to encompass all the 
selected objects. You can then rearrange and resize the work area of the 
UserObject, and move the UserObject to an appropriate place in the 
work area. But the cleanup is easier if you place the objects logically 
beforehand.

You can use Edit ⇒ Clean Up Lines to clean up the line routing within 
your program. However, the command is context dependent. To clean up the 
lines for the UserObject, it must be the active window. Click on the 
UserObject window, then, use Edit ⇒ Clean Up Lines.

Creating a UserObject in its edit window and then using the icon view of 
the UserObject lets you save screen space. 
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To help you keep track of the UserObject, change the title from 
UserObject to AddNoise. Double-click on the title and enter the new title 
in the properties dialog box. While you are at it, change the title of the Real 
Slider to Noise Amplitude. The following figure shows how this makes 
the program easier to follow. Also, in the figure, the small box showing 
0.495 shows that the value on the output pin matches the value shown on 
the real slider (Noise Amplitude), and the bottom of the work space 
shows the minimized UserObject window (AddNoise).

 

The key to the proper use of a UserObject is to make sure it has a logical 
purpose within the program. Thus, this unique object is not just a space 
saving device, but rather a way of structuring your program. UserObjects 
help you use "top-down" design in your HP VEE programs. For more 
information, select Help ⇒ Contents and Index from the HP VEE 
menu bar. Then, browse How Do I..., Tell Me About..., or Reference.

We’ll continue with this example in the following section, so if you want to 
quit now, save your program (simple-program.vee).
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Creating a Panel View

After you develop a program, you will often want to give it an operator 
interface. To do this, you can create a panel view of the program. Let’s 
continue with our previous example to see how this is done.

1. Open your program (simple-program.vee) if it is not already in the 
work area.

2. Select the Real Slider and Waveform (Time)objects. To do this, use 
the shortcut; Ctrl+left mouse button. 

3. Click the Add to Panel button on the toolbar to add the selected 
objects to the panel (or use Edit ⇒ Add To Panel). A panel view 
appears, showing the two objects that you added to the panel.

You can size and move the objects in the panel view to appropriate locations 
to create a panel similar to the one shown in the next figure.

 

Try pressing the Detail button on the Main window title bar to go to the 
detail view. Then, click on the Panel button to return to the panel view.

The detail view is the normal window in which you edit your program. You 
can move, resize, or delete objects in the panel view independently from the 
detail view; but the idea is to use the detail view to develop a program and 
use the panel view to provide an operator interface. (For more information, 
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select Help ⇒ Contents and Index. Then, select How Do I... Finally, 
select Build an Operator Interface.)

Again, save your program (simple-program.vee) if you want to quit 
now.

Using Data Files

You can write data from HP VEE to a data file, and read the data in a file 
into HP VEE, by including the To File and From File objects in your 
program. As an example, add a To File object to the detail view of the 
program you’ve been building (if necessary, click on the icon that switches 
you from panel view to detail view. It’s in the title bar for the Main window).

Open the program (simple-program.vee), if it isn’t already in your work 
area. (Be in the detail view.) Now add a To File object to the work area 
(I/O ⇒ To ⇒ File):

 

Change the name of the data file (the To File: field, which by default is 
myFile) to wavedata by clicking on myFile. The following dialog box 
appears.
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Backspace over myFile, type in the new name, and then click on OK. Also, 
click on the checkbox in the To File object to activate Clear File at 
PreRun and Open as indicated in the next figure.

 

Now double-click on the write transaction labeled WRITE TEXT a EOL. 
The I/O Transaction dialog box appears in the next figure.
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Click on the TEXT field (or its arrow) to show the drop-down list of data 
types. Click on CONTAINER, and then on OK, to change the transaction to 
WRITE CONTAINER a. Connect the data output pin of the AddNoise user 
object to the data input pin of the To File object, as shown in the next 
figure.
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Now the program not only displays the noisy sine wave output by the 
AddNoise UserObject, but also writes a container of waveform data to 
the file wavedata.

Let’s add a From File object (I/O ⇒ From ⇒ File) to the program to 
read the data back. You’ll need to change the read transaction to READ 
CONTAINER x and the file name to wavedata (the procedure is the same as 
for To File). Now delete the line between AddNoise and the Waveform 
(Time) object, and connect the objects as shown.

 

Note that when the To File object finishes executing (after it has written to 
the file wavedata) it activates the sequence input pin on the From File 
object, which reads the container of data and outputs the waveform to the 
display object.

Click on the Panel button in the Main window. You’ll find that the panel 
view has not been changed by changes you made to the detail view.

For more information, select Help ⇒ Contents and Index from the 
HP VEE menu bar. Then, browse How Do I..., Tell Me About..., or 
Reference.
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Mathematically Processing Data

HP VEE provides extensive mathematical capabilities and data type support. 
This information is documented in topics in the Tell Me About... online 
help, which you access via Help ⇒ Contents and Index. 

To Use Data Types HP VEE supports several data types, including text, integer and real 
numbers, and several types of complex and coordinate numbers. You have 
already seen how the A+B object can add two waveforms together in our 
earlier examples. In fact, the mathematical operators such as + can act on 
several data types, and can even act on mixed data types. Let’s look at an 
example.

To create the following program, clear the Main window, place the 
following objects in the Main window, and connect them as shown, noting 
the following information.

n For the Real Constant object, select:
Data ⇒ Constant ⇒ Real.

n For the Complex Constant object, select:
Data ⇒ Constant ⇒ Complex.

n For the A+B object, select:
Device ⇒ Function & Object Browser to get the Function & 
Object Browser. Then, in order, select Type: Operators; 
Category: Arithmetic; Member: +.

n For the AlphaNumeric object, select:
Display ⇒ AlphaNumeric.

Now type the value, 1.53, in the data entry field of the Real object, and the 
complex value, (2,1), in the Complex object. Run the program and you 
should get the following result.
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HP VEE automatically converts the data as needed, then performs the 
addition in the A+B object. The real value 1.53 is converted to the complex 
value (1.53,0), which is then added to the complex value (2,1). The 
result, (3.53,1) (a complex number), is displayed in the AlphaNumeric 
object.

Normally, HP VEE takes care of all data type conversions for you. For more 
information, select Help ⇒ Contents and Index from the HP VEE 
menu bar. Then, browse How Do I..., Tell Me About..., or Reference.

To Use Data Shapes HP VEE supports a variety of data shapes, such as scalars and arrays. Unlike 
most programming languages, HP VEE objects can operate on an entire 
array, rather than on only one element.

The following program creates a one-dimensional, ten-element array, 
calculates the median of the 10 values, and then displays the median value. 

To create the program, clear the Main window, place the following objects 
in the Main window, and connect them as shown:

n For the For Range object, use:
Flow ⇒ Repeat ⇒ For Range.

n For the Sliding Collector object, use:
Data ⇒ Sliding Collector.

n For the median(x) object, use the following selections; noting that, 
once you select median, click on OK. You might need to scroll through 
some lists. Select Device ⇒ Function & Object Browser to get the 
Function & Object Browser. Then, in order, select Type: Built-
in Functions; Category: Probability & Statistics; 
60 Chapter 2 



HP VEE Programming Techniques
General Techniques
Member: median. (You can shorten this by first clicking on the fx 
button to get the Function & Object Browser.)

n For the AlphaNumeric object, use:
Display ⇒ AlphaNumeric.

 

To Use the Formula 
Object

HP VEE provides mathematical operators and functions, all of which are 
documented in the Reference. (Select Help ⇒ Contents and Index. 
Then, select Reference and browse the items as desired).

The predefined operator and function objects are available via 
Device ⇒ Function & Object Browser (or fx on the toolbar). You 
select them from the Function & Object Browser by clicking on 
entities in three lists; Type:, Category:, and Member:. You verify your 
selected object with OK. 

Besides using predefined operators and functions, you can create any valid 
HP VEE mathematical expression within the Formula object, which is 
found under the Device menu. This section has you examine Formula 
objects.

To create a program for using a Formula object, clear the Main window and 
follow these steps:

1. Add the Function Generator object to the Main window and modify 
it to produce a 100 Hz sine wave.

2. Add the Formula object to the Main window. Add a second input (B) to 
the object (put the mouse pointer in the input terminal area and use 
Ctrl+A). 

3. Type the mathematical expression abs(A)+B in the entry field.
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4. Add a Real constant object to the Main window. (Data ⇒ Constant 
⇒ Real), and type in the value 0.5.

5. Add the Waveform (Time) display object and set the y-axis scale to -2 
through 2. Set Automatic Scaling to Off. To get the dialog box for 
these parameters, click on Mag.

6. Connect the objects as shown in the next figure.

 

When you run the program, the Formula object takes the waveform input A 
and the real value B, and adds B to the absolute value of A. In effect, the 
expression abs(A)+B "rectifies" the sine wave and adds a "dc offset." You 
could have produced the same effect by using the A+B and abs(x) objects, 
but it is easier to read an expression in a Formula object. (This also saves 
space.)

Try double-clicking on the input and output terminals of the Formula 
object. Note that the real scalar on input B is added to each element of the 
waveform data (a one-dimensional array) on input A, and the resulting 
waveform is output on the Result terminal.
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Communicating with Instruments 
HP VEE provides extensive capabilities to communicate with and control 
test instruments. There are several types of instrument I/O objects.

n VXIplug&play is a library of functions for controlling a specific 
instrument.

n Direct I/O provides a means of direct communication with an instrument 
without the use of an instrument driver file.

n Panel Driver provides a "front panel" to control a particular instrument. 
When you change parameters in the HP VEE instrument panel, the 
corresponding state of the instrument is changed.

n A Component Driver provides similar capabilities to those of an 
instrument panel, but without the "front panel," and without direct 
control over the state of the instrument.

This section introduces the use of a Panel Driver. For more information, see 
the manual, Controlling Instruments with HP VEE. Also, see HP VEE Help 
(Help ⇒ Contents and Index. Then, browse How Do I..., Tell Me 
About..., or Reference).

Note VXIplug&play requires that a VXIplug&play Driver be present for a 
particular instrument. Panel and Component Drivers require that an 
HP Panel Driver (.CID) file be present for the particular instrument. The 
examples in this section use the HP 3325B Function Generator with an 
HP Panel Driver. The panel driver file for this instrument is installed by 
default as part of the HP VEE installation.

Configuring Instruments       

In the following example you configure an instrument panel for an 
HP 3325B Function Generator. You probably don’t have one hooked up, but 
don’t worry. One of the powerful features of HP VEE instrument I/O is that 
you can configure an instrument panel and create a program with Live 
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Mode OFF. This means that the instrument need not be connected to your 
computer. Or the instrument can be connected, but in Live Mode OFF 
HP VEE won’t communicate with it. This lets you test much of your 
program before you connect the instrument and communicate with it.

To configure the HP 3325B instrument panel, clear the work area and follow 
these steps:

1. Select I/O ⇒ Instrument Manager... The Instrument Manager 
dialog box appears. Several selections appear. Please don’t delete them. 
They are used in example programs provided with HP VEE. You might, 
for example, click on fgen (hp3325b@(NOT LIVE)).

2. The dialog box has several parts; Instrument List, Configuration, 
and Create I/O Object. Configure a new instrument by clicking on 
the Add Instrument... button under Configuration. A dialog box 
appears. Your screen might be slightly different, but the essential parts 
are present as shown next.
 

You edit the fields in this dialog box to add a function generator to your 
list of instruments. However, when you change values, do not press 
Enter. You might exit the dialog box. Instead, after you edit a field, click 
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on the next field you want to edit, or use the Tab key to advance through 
the fields.

3. The Name field is currently highlighted. Enter a new name (for example, 
FncGen) to start your new configuration. 

4. Now click on the Address field and enter the address of your 
instrument. Typically, the address for the HP 3325B Function Generator 
is 707. (With real instruments, for information about addressing an 
instrument, refer to the instrument’s documentation.)

5. Click on the Advanced I/O Config... button. The following dialog 
box appears. The Live Mode field in the Advanced Device 
Configuration dialog box shows ON at this point because you entered 
a non-zero address. Click on ON to change it to OFF.
 

Click on the Panel Driver tab, and then click on the ID Filename: 
field. This pops up a Read from what Instrument Driver? dialog 
box. From the list, click on hp3325b.cid, and then click on Open.

6. Click on General in the Advanced Device Configuration... 
dialog box. Note that the Live Mode: field should show OFF. If it does 
not, click on the field to get Live Mode: to OFF. Click on OK to return to 
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the Device Configuration dialog box, and click on OK to return to 
the Instrument Manager dialog box, as shown in the next figure.
 

The new selection, FncGen(@(NOT LIVE)), appears in the list of 
instruments that you can select. 

7. Now click on the Save Config button. The dialog box disappears and 
your new instrument configuration has been saved.

Your FncGen configuration is complete, and the configuration will be 
available whenever you start HP VEE. Now let’s use this configuration. 

Using an Instrument Panel

The open view (contrasted with the minimized view) of an HP VEE 
instrument panel object represents the front panel of your physical 
instrument. Just as you can change the settings on your physical instrument’s 
panel, you can change the settings on the instrument panel objects in 
HP VEE. If your instrument is connected and live mode is ON, any valid 
changes you make on the HP VEE instrument panel will control the physical 
instrument, just as if you made the changes on that instrument’s front panel. 
Let’s continue with our example:
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1. Select I/O ⇒ Instrument Manager... again. The Instrument 
Manager dialog box appears. Click once, if necessary, to highlight 
FncGen(@(NOT LIVE)). 

2. Then, click on the Panel Driver button. An outline of the FncGen 
instrument panel object appears in the Main window. Place the outline 
where you want it, and click the mouse button.
 

Click on Sine. A dialog box gives you a series of choices for the 
Function field. Double-click on Square to change the shape of the 
waveform. (If a function generator was connected, and live mode was ON, 
this change would also occur on the physical instrument.)

3. Click on the Main Panel field. A dialog box lists the panels for this 
particular instrument. Each panel allows you to change various 
instrument parameters. To try this, go to another panel; for example, the 
Sweep or Modulation panels. To do this, double-click on the panel 
name, or click on the panel name and then click on OK. The panel you 
selected appears in place of the main panel. By using the various panels, 
you can interactively access and control the features of the instrument.

4. Return to the main panel by clicking on the panel field and selecting 
Main Panel.
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Using an Instrument Panel in a Program

Let’s create a program that uses the FncGen object to control the frequency 
of the function generator in a step-wise fashion. To do this, follow these 
steps:

1. Add a Frequency data input terminal to the FncGen object. To do this, 
select Add Terminal ⇒ Data Input in the object menu. A dialog box 
lists the possible input terminals that you can add. Click on Frequency 
and then click on OK.

2. Add a For Range object (Flow ⇒ Repeat ⇒ For Range). Change the 
parameters as follows: From = 10k, Thru = 100k, and Step = 10k. 
(You can type either 10k or 10000.)

3. Add a Delay object (Flow ⇒ Delay). Click on the recessed field and 
enter 1 for the delay in seconds.

4. Connect the objects as shown in the next figure.

 

When you run the program, the For Range object steps the function 
generator through frequencies of 10 kHz, 20 kHz, and so forth, up to 100 
kHz. Because of the Delay object, each loop takes 1 second.
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If you have an HP 3325B Function Generator connected to your computer, 
you can turn live mode ON and control your real instrument. To do this, 
select I/O ⇒ Instrument Manager..., and then select FncGen 
(HP3325B @(NOT LIVE)). Click on Edit Instrument... Click on 
Advanced I/O Config.... Click on the Live Mode: field (it changes 
from OFF to ON). Then, click on OK to return to Device Configuration. 
Click on OK to return to the Instrument Manager. Click on Save 
Config to save the new configuration. Now try the program again and 
watch the front panel of your physical instrument. For more information, 
select Help ⇒ Contents and Index from the HP VEE menu bar. Then, 
browse How Do I..., Tell Me About..., or Reference.

Getting Instrument Help

You can get online help for any instrument for which you installed an 
instrument driver. When you install a driver, the program also installs a help 
file for the driver. The instrument driver help files do not use the same help 
system as the other HP VEE help files, but you do get help. 

To get help, select Help ⇒ Instruments... From the list, click on the 
help file for your instrument; for example, hp3325b.ih. Open the file and 
you get help as shown in the next figure. Select the help you want according 
to the topics; for example, Using the Panel. 
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What’s Next?
Now that you’ve finished our short introduction to HP VEE’s capabilities, try 
some things on your own. Use the following information to help you:

n The online help is a good place to start (click on Help in the HP VEE 
menu). The online help discusses instruments, has an open example, 
discusses HP VEE, explains how to use help, and contains online 
contents. Clicking on Contents and Index presents browsable items; 
for example, How Do I... and Tell Me About... Collectively, 
these items explain how to use HP VEE. You can browse topics as 
desired, and you can print the information.

n The Controlling Instruments with HP VEE manual explains how to 
control instruments via HP VEE programs. 

n The HP VEE Advanced Programming Techniques manual provides 
detailed information about the advanced features of HP VEE.

n The Reference, which you reach via Help ⇒ Contents and Index, 
provides specific information about objects, menu items, error codes, 
math functions, operators, and glossary items. There is even an ASCII 
table.
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Glossary

This Glossary defines terms used in this manual. For a complete glossary of 
HP VEE terms, select Help ⇒ Contents and Index. Then, select 
Reference. Finally, select Glossary. In the glossary, clicking on a term 
displays a definition. When you finish reading the definition, clicking 
anywhere dismisses it.

Button
A graphical object in HP VEE that simulates a momentary switch or 
selection button, and which appears to pop out from your screen. When 
you "press" a button in HP VEE, by clicking on it with the mouse, an 
action occurs. (May also refer to the left or right mouse button.)

Cascading Menu
A sub-menu on a pull-down or pop-up menu that provides additional 
selections.

Checkbox
A recessed square box on HP VEE menus and dialog boxes that allows 
you to select a setting. To select a setting, click on the box and a check 
mark appears in the box to indicate a selection has been made. To cancel 
the setting, simply click on the box again.

Click
To press and release a mouse button. Clicking usually selects a menu 
feature or object in the HP VEE window. See also Double-Click and 
Drag.

Clone
A menu item on the HP VEE object menus, that duplicates objects and 
their interconnections, placing a copy of them in the Paste buffer. 
Clone copies all the attributes of the cloned objects including pins, 
parameters, and size.
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Component 
A single instrument function or measurement value in an HP VEE 
instrument panel or component driver. For example, a voltmeter driver 
contains components that record the range, trigger source, and latest 
reading.

Component Driver
An instrument control object that reads and writes values to components 
you specifically select. Use component drivers to control an instrument 
using a driver by setting the values of only a few components at a time. 
(Component drivers do not support coupling.)

Container
See Data Container.

Context
A level of the work area that can contain other levels of work areas (such 
as nested UserObjects), but is independent of them.

Cursor
A pointer (caret) in an entry field that shows where alphanumeric data 
will appear when you type information from the keyboard.

Cut Buffer 
The buffer that holds objects that you cut or copy. You can then paste the 
object back into the work area with the Paste toolbar button 
(Edit ⇒ Paste).

Data Container 
The data package that is transmitted over lines and is processed by 
objects. Each data container contains data and the data type, data shape, 
and mappings (if any).

Data Flow
The flow of data through and between HP VEE objects. Data flows from 
left to right through objects, but an object does not execute until it has 
data on all of its data input pins. Data is propagated from the data output 
pin of one object to the data input pin of the next object. Data flow is the 
chief factor that determines the execution of an HP VEE program.
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Data Input Pin
A connection point on the left side of an object that permits data to flow 
into the object.

Data Output Pin
A connection point on the right side of an object that propagates data 
flow to the next object and passes the results of the first object’s operation 
on to the next object.

Data Shape
Each data container has both a shape and type. The data shape can be 
either a scalar or an array of one or more dimensions. In HP VEE, a one-
dimension array is called Array 1D, a two-dimension array is Array 2D, 
and so forth.

Data Type
Each data container has both a type and shape. HP VEE supports several 
data types including Text, Real, and Integer.

Detail View
The view of an HP VEE program that shows all the objects and the lines 
that connect them.

Direct I/O Object
An instrument control object that allows HP VEE to directly control an 
instrument without using an instrument driver.

Double-Click
To press and release a mouse button twice in rapid succession. Double-
clicking is usually a short-cut to selecting and performing an action. For 
example, double-clicking on a file name from File ⇒ Open will select 
the file and open it.

Drag
To press, and continue to hold down, a mouse button while moving the 
mouse. Dragging moves something (for example, an object or scroll bar).
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Drop-Down List
A list of selections obtained by clicking on the arrow to the right of a 
selection field.

Entry Field 
A field that is typically part of a dialog box or an editable object, which is 
used for data entry. An entry field is editable when its background is 
white.

Expression
An equation in an entry field that may contain input terminal names, 
global variable names, math functions, and user-defined functions. An 
expression is evaluated at run time. Expressions are allowed in Formula, 
If/Then/Else, Get Values, Get Field, Set Field, Sequencer, 
and Dialog Box objects, and in I/O transaction objects.

Font
HP VEE allows you to change the "font" — the size and style of type
used to display text for various HP VEE objects, titles, and so forth.

Grayed Feature
A menu feature that is displayed in gray rather than black, indicating 
the feature is not active or not available. Dialog box items such as 
buttons, checkboxes, or radio buttons may also be grayed.

Group Window
A group window in Microsoft Windows is a window that contains icon
for a group of applications. Each icon starts an application in the grou

HP-UX
The derivative of the UNIX operating system that has been develope
Hewlett-Packard Company.

Hypertext
A system of linking topics so that you can jump to a related topic whe
you want more information. In online help systems, typically hypertex
links are designated with underlined text. When you click on such tex
related information is presented.
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Icon
1. A small, graphical representation of an HP VEE object, such as the 
representation of an instrument, a control, or a display.

2. A small, graphical representation of an application, file, or folder in the 
Microsoft Windows and HP-UX (with VUE) operating systems.

Main Window
A window that contains the primary work area in which you develop an 
HP VEE program. The work area for this window resides in the work 
space for the HP VEE window.

Maximize Button
A button on a UserObject, UserFunction, or the Main window, that 
makes the UserObject, UserFunction, or Main window, occupy all 
of the available work space.

Menu Bar
The bar at the top of the HP VEE window that displays the titles of the 
pull-down menus from which you select commands and objects.

Minimize Button
A button on an object, or the HP VEE window, that iconifies the object, 
or the HP VEE window.

Object
A graphical representation of an element in a program, such as an 
instrument, control, display, or mathematical operator. An object is 
placed in the work area and connected to other objects to create a 
program.

Object Menu 
The menu associated with an object that contains features that operate on 
the object (for example, moving, sizing, copying, and deleting the 
object). To obtain the object menu, click on the object menu button at the 
upper-left corner of the object, or click the right mouse button with the 
pointer over the object.
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Object Menu Button 
The button at the upper-left corner of an open view object, which 
displays the object menu when you click on it.

Open View
The representation of an HP VEE object that shows more detail than the 
minimized view (icon). Most object open views have fields that allow 
you to modify the operation of the object.

Panel Driver
An instrument control object that forces all the function settings in the 
corresponding physical instrument to match the settings in the control 
panel displayed in the open view of the object.

Panel View
The view of an HP VEE program, or of a UserObject or 
UserFunction, that shows only those objects needed for the user to run 
the program and view the resulting data. You can use panel views to 
create an operator interface for your program.

Pin (or Pins)
An external connection point on an object to which you can attach a line.

Pointer
The graphical image that maps to the movement of the mouse. The 
pointer allows you to make selections and provides you feedback on a 
particular process underway. HP VEE has pointers of different shapes 
that correspond to process modes, such as an arrow, crosshairs, and 
hourglass.

Pop-Up Menu
A menu that is raised by clicking the right mouse button. For example, 
you can raise the Edit menu by clicking the right mouse button in an 
empty area within the work area. Or you can raise the object menu by 
clicking the right mouse button on an inactive area of an object.
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Preferences
Preferences are attributes of the HP VEE environment that you can 
change using the Default Preferences button on the toolbar, or the 
menu File ⇒ Default Preferences. For example, you can change 
the default colors, fonts, and number format.

Program
In HP VEE, a graphical program that consists of a set of objects 
connected with lines. The program typically represents a solution to an 
engineering problem.

Program Explorer
A facility in the HP VEE window that permits exploration of a program, 
especially the parts of a program that might not be visible on the physical 
screen.

Propagation
The rules that objects and programs follow when they operate or run. See 
also Data Flow.

Properties
Object properties are attributes of HP VEE objects that you can change 
using Properties on the object menu; for example, colors, fonts, and 
titles.

Pull-Down Menu
A menu that is pulled down from the menu bar when you position the 
pointer over a menu title and click the left mouse button.

Scroll Arrow
An arrow that, when clicked on, scrolls through a list of data files or other 
choices in a dialog box, or moves the work area.

Scroll Bar
A rectangular bar that, when dragged, scrolls through a list of data files or 
other choices in a dialog box, or moves the work area.
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Select
To choose an object, an action to be performed, or a menu item. Usually 
you select by clicking with your mouse.

Selection Field
A field in an object or dialog box that allows you to select choices from a 
drop-down list.

Sequence Input Pin
The top pin of an object. When connected, execution of the object is held 
off until the pin receives a container (is "pinged").

Sequence Output Pin
The bottom pin of an object. When connected, this output pin is activated 
when the object and all data propagation from that object finishes 
executing.

Status bar
A line at the bottom of the HP VEE window in which information about 
the current status of and information about HP VEE is displayed.

Status field
A field displaying information that cannot be edited. A status field looks 
like an entry field, but has a gray background.

Terminal
The internal representation of a pin that displays information about the 
pin and the data container held by the pin. Double-click on a terminal to 
view the container information.

Title Bar 
The rectangular bar at the top of the open view of an object or window, 
which shows the title of the object or window. You can turn off an object 
title bar using Properties in the object menu.

Toolbar 
The rectangular bar at the top of the HP VEE window which provides 
buttons for quick access to frequently used commands. The buttons run 
commands from menus such as File, Edit, View, Device, and Debug.
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Transaction
The specifications for input and output (I/O) used by certain objects in 
HP VEE. Examples include the To File, From File, Direct I/O, 
and Sequencer objects. Transactions appear as phrases listed in the 
open view of these objects.

UserObject
An object that can encapsulate a group of objects to perform a particular 
purpose within a program. A UserObject allows you to use top-down 
design techniques when building a program, and to build user-defined 
objects that can be saved in a library and reused.

Views
HP VEE presents a program in one of two views; panel view, which 
provides a user interface for an HP VEE program, or detail view, which 
provides a window for developing an HP VEE program.

Windows 95
An operating system, developed by Microsoft Corporation, in which 
HP VEE runs.

Windows NT
An operating system, developed by Microsoft Corporation, in which 
HP VEE runs.

Work Area
An region within the Main window (also the UserObject and 
UserFunction windows) in which you place HP VEE objects and wire 
them together to create an HP VEE program.

Work Space
A region in the HP VEE window that contains the programming or 
editing windows such as Main, UserObject, and UserFunction. 
These windows contain work areas in which you place HP VEE objects 
and wire them together.
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A
adding objects, 8
arrays, 60
arrow

scroll, 23

B
bar, scroll, 23
button

minimize, 10
mouse, 4
object menu, 10

C
cascading menu, 7
changing

preferences, 24
properties, 15, 27
settings, 24

clearing the work area, 16
click, 4
cloning an object, 13
cloning objects, 20
component driver, 63
configuring instruments, 63–66
copying multiple objects, 22
copying objects, 20
creating a UserObject, 49–53
cutting an object, 13
cutting and pasting objects, 19

D
data

files, 55–58
flow, 42–46
mathematically processing, 59–62
shapes, 60
types, 59

deleting an object, 13
detail view, 54
dialog box, 3
direct I/O, 63
double-click, 4

drag, 4
dragging an object, 11
duplicating an object, 13

E
Edit menu, 18
editing multiple objects, 21–23

F
files

opening, 41
program, 40

flow, data, 42–46
Formula object, 61–62
From File object, 55–58

H
help

instrument, 69
online, 3, 30–31

HP VEE
defined, 2
interacting with, 3–31
objects, 7
printing, 39
Program Explorer, 6
programming with, 32–46
quitting, 7
run-time environment, 2
starting, 4
work area, 6
work space, 6

HP VEE window, 5

I
icon, 10
instrument panel, 63

programming, 68–69
using, 66–67

instruments
configuring, 63–66
help, 69
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L
live mode ON/OFF, 63

M
Main window, 6
managing the work space, 16
mathematically processing data, 59–62
menu

cascading, 7
pop-up, 11, 18
selecting, 3

menu bar, 6
Microsoft Windows, 3
minimize button, 10
mouse button, 4
moving an object, 11
moving the work area, 23

O
object menu

button, 10
selecting, 11

object title, 15
objects, 7

adding, 8
changing parameters, 35–38
cloning, 13, 20
copying, 20
cutting, 13
cutting and pasting, 19
deleting, 13
dragging, 11
duplicating, 13
moving, 11
multiple, 21–23
multiple copying, 22
pasting, 13
resizing, 14
selecting, 19

online help, 3, 30–31
open view, 10
opening a file, 41
operator interface, creating, 54–55

P
panel view, 54
panel view, creating, 54–55
panel, instrument, 66–69
parameters

changing, 35–38
pasting an object, 13
pins, 26
pop-up menu, 11, 18
preferences

changing, 24
printers, using with HP VEE, 39
printing the screen, 39
Program Explorer, 6

showing it, 16
program files, 40
programming

general techniques, 49–62
HP VEE, 32–46
I/O techniques, 63–69

programs
creating, 32–34
opening, 41
running, 34
saving, 40

propagation, 42
properties

changing, 15, 27

Q
quitting HP VEE, 7

R
resizing an object, 14
run-time environment, 2

S
saving a program, 40
scalars, 60
scroll arrow, 23
scroll bar, 23
scrolling the work area, 23
selecting menus, 3
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selecting multiple objects, 21–23
selecting objects, 19
selecting the Edit menu, 18
settings

changing, 24
showing the Program Explorer, 16
starting HP VEE, 4
status bar, 6
supported systems, 3
systems

supported, 3

T
terminals, 26

adding, 28
deleting, 30
obtaining information, 28

title
object, 15

title bar, 6
To File object, 55–58
toolbar, 3, 6

U
user interface, 3
UserObject, creating, 49–53
using data files, 55–58

V
view

detail, 54
panel, 54

W
window

HP VEE, 5
Main, 6

work area, 6
clearing, 16
moving, 23

work space, 6
managing it, 16
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	The Copy command copies the selected object into the cut buffer. Then, you can Paste the object i...

	To Select Multiple Objects
	To Copy Multiple Objects
	There are two methods for copying several, selected objects.


	Note In HP�VEE for Windows, objects that you cut or copy, are also placed on the Clipboard. You c...
	To Move the Work Area
	To Change Default Preferences
	Understanding Pins and Terminals

	To Add a Terminal
	You can add a second data input terminal to the Formula object. In the object menu, select Add Te...

	To Obtain Terminal Information
	To Delete a Terminal
	Getting Help
	HP�VEE uses an online help viewer that is designed for your operating system. Click on Help and t...



	Note As a shortcut to get help on a selected object and on dialog boxes, press F1.

	Programming with HP�VEE
	A Simple Program
	To Create a Simple Program
	Note If your lines appear to be scrambled, use Edit ﬁ Clean Up Lines to reroute the lines in your...
	To Run Your Program

	Note From now on, when we say to “run” your program, just click on the Run button on the toolbar,...
	To Change Object Parameters
	1. Click on Deg (or the arrow) in the Function Generator object and change the phase units to Rad...
	2. The y-axis limits of the Waveform (Time) object are preset to -1 through 1. Click on the y-axi...

	To Print the Screen
	To print the screen, select File ﬁ Print Screen.

	To Save Your Program

	Note In HP�VEE for Windows, you can use the long file names allowed by Windows 95 and Windows NT.
	Note To re-save your program to the same file name click the Save button or press Ctrl+S at any t...
	To Open a File
	How HP�VEE Programs Work
	In conventional programming languages such as C, BASIC, or Pascal, the order in which program sta...
	1. Minimize the Function Generator to its icon.
	2. Add the Noise Generator object (Device ﬁ Virtual Source ﬁ Noise Generator).
	3. Add the A+B object. (Use Device ﬁ Function & Object Browser. Then, in the Function & Object Br...
	4. Connect the input and output pins as shown in the previous figure.
	5. Run the program.




	Note Show Execution Flow and Show Data Flow can be enabled together or individually by clicking o...
	Try changing the amplitude of the noise (drag the slide control on the Real Slider object). The a...
	Again, data flow determines the order of execution. The Noise Generator can’t execute until the R...



	2 HP�VEE Programming Techniques
	HP�VEE Programming Techniques
	General Techniques
	Creating a UserObject
	Note Rearranging the positions of the objects before executing Create UserObject is one of conven...
	Creating a Panel View
	1. Open your program (simple-program.vee) if it is not already in the work area.
	2. Select the Real Slider and Waveform (Time)objects. To do this, use the shortcut; Ctrl+left mou...
	3. Click the Add to Panel button on the toolbar to add the selected objects to the panel (or use ...

	Using Data Files
	Mathematically Processing Data
	To Use Data Types
	To Use Data Shapes
	To Use the Formula Object
	1. Add the Function Generator object to the Main window and modify it to produce a 100 Hz sine wave.
	2. Add the Formula object to the Main window. Add a second input (B) to the object (put the mouse...
	3. Type the mathematical expression abs(A)+B in the entry field.
	4. Add a Real constant object to the Main window. (Data ﬁ Constant ﬁ Real), and type in the value...
	5. Add the Waveform (Time) display object and set the y-axis scale to -2 through 2. Set Automatic...
	6. Connect the objects as shown in the next figure.



	Communicating with Instruments
	Note VXIplug&play requires that a VXIplug&play Driver be present for a particular instrument. Pan...
	Configuring Instruments
	1. Select I/O ﬁ Instrument Manager... The Instrument Manager dialog box appears. Several selectio...
	2. The dialog box has several parts; Instrument List, Configuration, and Create I/O Object. Confi...
	3. The Name field is currently highlighted. Enter a new name (for example, FncGen) to start your ...
	4. Now click on the Address field and enter the address of your instrument. Typically, the addres...
	5. Click on the Advanced I/O Config... button. The following dialog box appears. The Live Mode fi...
	6. Click on General in the Advanced Device Configuration... dialog box. Note that the Live Mode: ...
	7. Now click on the Save Config button. The dialog box disappears and your new instrument configu...

	Using an Instrument Panel
	1. Select I/O ﬁ Instrument Manager... again. The Instrument Manager dialog box appears. Click onc...
	2. Then, click on the Panel Driver button. An outline of the FncGen instrument panel object appea...
	3. Click on the Main Panel field. A dialog box lists the panels for this particular instrument. E...
	4. Return to the main panel by clicking on the panel field and selecting Main Panel.

	Using an Instrument Panel in a Program
	1. Add a Frequency data input terminal to the FncGen object. To do this, select Add Terminal ﬁ Da...
	2. Add a For Range object (Flow ﬁ Repeat ﬁ For Range). Change the parameters as follows: From = 1...
	3. Add a Delay object (Flow ﬁ Delay). Click on the recessed field and enter 1 for the delay in se...
	4. Connect the objects as shown in the next figure.

	Getting Instrument Help
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