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About this Manual
This manual explains how to install HP VEE on an HP Series 700 HP-UX 
system. The applicable versions of HP-UX are 9.x, 10.01, and 10.20. The 
manual assumes you are familiar with HP-UX. No attempt is made to 
provide system administration information for HP-UX.
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Conventions Used in This Manual
This manual uses the following typographical conventions:

Getting Started Italicized text is used for book titles and for 
emphasis.

Dialog Box Bold text is used for the first instance of a word 
that is defined in the glossary.

File Computer font represents text that you will see 
on the screen, including menu names, features, 
buttons, or text that you have to enter.

dir filename In this context, the text in computer font 
represents an argument that you type exactly as 
shown, and the italicized text represents an 
argument that you must replace with an actual 
value.

File ⇒ Open The “⇒” is used in a shorthand notation to show 
the location of HP VEE features in the menu. For
example, “File ⇒ Open” means to select the 
File menu and then select Open.

Sml | Med | Lrg Choices in computer font, separated with bars 
(|), indicate that you should choose one of the 
options.

Press Enter In this context, bold represents a key to press on
the keyboard.

Press Ctrl + O Represents a combination of keys on the 
keyboard that you should press at the same time
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Installing HP VEE

This chapter explains the requirements for installing HP VEE Version 5.0 
(hereafter called HP VEE unless the version designation is required). It also 
describes the installation procedure according to your type of HP-UX system 
(for example, a cluster server), and your version of HP-UX (for example, 
version 10.20). (Chapter 2 examines things you can do after you perform the 
installation.)
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Installing HP VEE
Orientation
Orientation
While this manual is rather lengthy, you will not use all of it. The intent was 
to develop a document that discussed all the scenarios for installing 
HP VEE. Therefore, you should work through the following sections and 
specific steps according to your situation, needs, and experience.

Version Requirements

HP VEE runs on all 9.x versions of HP-UX. It also runs on the 10.01 and 
10.20 versions. HP VEE does not run on the 10.00 or 11.0 versions, and 
there is no support for clustered clients on the 10.01 version. The primary 
difference between the 9.x versions and any 10.xx version is the structure of 
the file system, and this impacts the HP-UX commands you use to install 
HP VEE.

Note There were many patches for HP-UX between versions 10.01 and 10.20. If 
you have questions about patches, call your HP support person. However, no 
patches are known to affect installing and using HP VEE.
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Installing HP VEE
Orientation
Hardware Requirements    

n A Series 700 HP-UX workstation that has an EISA slot. 

n 64 MB RAM.

n At least 80 MB free space on the hard disk that contains /usr/lib on 
version 9.x or /opt on version 10.x. 

n At least 20 MB swap space in addition to the swap space required to run 
other parts of HP-UX; for example, X11 Windows or another application. 

n At least a 17-inch display with at least Super VGA capability; for 
example, 1024x768 resolution. An equivalent gray-scale display can be 
used. 

n CD-ROM install drive.

n An HP LaserJet printer with at least 2 MB RAM is recommended.

Additional Software Requirements

You need to have, or account for, the following software:

n You need one of the following:

q X11 Windows (may ship with your HP-UX product).

q HP VUE (optional) (may ship with your HP-UX product).

n To do instrument I/O, you must install the HP I/O Libraries. This 
installation is done separately from this installation. It can be done before 
or after this installation. (See the HP VEE-Installing the HP I/O Libraries 
manual.)
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Installing HP VEE
Orientation
Interface Cards and Instrument I/O

HP VEE supports many interface cards that let you perform instrument I/O. 
The number and type of cards can change over time. For complete 
information, contact your HP sales office to obtain a recent list of supported 
cards. With this in mind, HP VEE is known to support the following 
interface cards.

Versions 9.x and 10.x

HP VEE internal I/O supports the following interfaces using HP Panel 
Drivers and Direct I/O:

n HP E2070 HP-IB Interface for Series 700 Computers 
n HP E2071 High Speed HP-IB Interface for Series 700 Computers 
n HP Model 745i, or V743 Built-in HP-IB Port 
n HP E2074 GPIO Interface for Series 700 Computers 
n HP Model V743 VXIbus 
n HP E1489 MXI Interface for the Series 700 Computers 
n HP Series 700 Built-in RS-232 Interface 
n HP Interpreted SCPI (I-SCPI) Interface for Series 700 
n HP Series 700 Built-in LAN interface or add-on LAN card

Version 10.x Addition

HP VEE supports the following interfaces using VXIplug&play Drivers:

n HP E2070 HP-IB Interface for Series 700 Computers
n HP E2071 High Speed HP-IB Interface for Series 700 Computers
n HP Model 745i, or V743 Built-in HP-IB Port
n HP Model V743 VXIbus
n HP E1489 MXI Interface for the Series 700 Computers
n HP Series 700 Built-in LAN interface or add-on LAN card

Note HP VEE does not support the GPIO or RS-232 interfaces for VXIplug&play 
on HP-UX 10.x.
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Installing HP VEE
Orientation
An Overview of the Installation

You must be the root user to install HP VEE. Stated differently, you must 
have superuser or system administration privileges. Performing an 
installation requires knowledge opf system administration. If you have no 
system administration experience, HP recommends you have a qualified 
person perform the installation. As well, if your HP-UX system is a client in 
a diskless cluster, the system administrator for the cluster must install 
HP VEE and make HP VEE available on your system. 

Impact on Previous Versions of HP VEE

If your system has an earlier version of HP VEE, installing HP VEE 5.0 
replaces your old HP VEE executable file, examples, and such. Your veeio 
and veerc files are retained.

To keep a previous version of HP VEE, move the directories in and below
/usr/lib/veetest (for versions 9.x) or /opt/veetest (for versions 
10.x) to another location. After you install HP VEE 5.0, to run the previous 
version, use the -d command-line option to specify the location of the old 
(renamed) directory.

Installation Commands

9.x Systems Use the /etc/update program to install HP VEE. If 
you need detailed information on the /etc/update 
program, refer to the HP-UX System Administration 
Tasks manual.

10.01 and 10.20 
Systems

Use the swinstall program to install HP VEE on 
stand-alone systems, and use the swcluster program 
to install HP VEE on clustered systems (the latter 
requires version 10.20). If you need information on the 
swinstall or swcluster programs, refer to the 
HP-UX System Administration Tasks manual.
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Orientation
The HP VEE 5.0 Environments

The HP VEE product, contains the HP VEE development environment and 
the HP VEE run-time environment (called HP VEE RunTime). Installing the 
development environment gives you all HP VEE functionality, including the 
run-time environment. After you develop HP VEE programs, and you want 
to use those programs on other HP-UX systems, you need to install the 
run-time environment on those systems.

The steps presented later for installing HP VEE mention both commands 
(installing the development environment or installing the run-time 
environment). You simply install the environment you need. The license for 
the installing the run-time environment is unrestricted.

Note Do not install the development environment on an HP-UX system and then 
subsequently install the run-time environment on that system. Install the 
run-time environment only on those systems that will run fully developed 
and operating HP VEE programs. The run-time environment has very 
limited functionality. 

Note The media you obtained has the HP VEE development and run-time 
environments. You also received media containing the HP I/O Libraries, 
which you install via a separate process (refer to the HP VEE-Installing the 
HP I/O Libraries for further information about the libraries). Make sure you 
install the Version 5.0 environments and libraries. You cannot use the 
HP I/O Libraries for a previous version of HP VEE with the 5.0 version.
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Installing HP VEE
Orientation
Installation Environments

You will install HP VEE from a CD-ROM. This manual accounts for both 
versions of HP-UX in separate sections. Depending on your version, look for 
the following sections:

n Installing HP VEE on HP-UX 9 

n Installing HP VEE on HP-UX 10:
Installation Steps on a Stand-Alone System 

n Installing HP VEE on HP-UX 10:
Installation Steps on a Clustered System

With this in mind, move on to the appropriate section.
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Installing HP VEE on HP-UX 9
Use this section if you have Version 9.x of HP-UX.

Overview

The HP VEE installation CD-ROM contains a mountable file system. The 
HP-UX update program expects the CD-ROM to be mounted on your file 
system. Your system must meet the following prerequisites before you 
mount the CD-ROM on your file system:

n The cdfs subsystem must be in your kernel. Use the HP-UX SAM 
program to verify the cdfs subsystem is in your kernel. If it isn’t, use 
SAM to add it.

n There must be an empty directory to use as a mount point. This example 
procedure assumes a directory called /cdrom. Your mount directory can 
have a different name. If needed, you can create this directory with the 
following command:

mkdir /cdrom 

n There must be a block-mode device special file on your system for the 
CD-ROM drive. This special file may already exist in the /dev/dsk 
directory. If you do not find it there, you can create one with the mknod 
command. When using the mknod command you must supply a major 
number. Use 7 for a SCSI CD-ROM drive. The following procedure 
assumes a block-mode device special file name of /dev/dsk/cdrom. 
Your special file can have a different name.

For further information about the HP-UX update program, refer to the 
Installing and Updating HP-UX manual.
Chapter 1 9



Installing HP VEE
Installing HP VEE on HP-UX 9
Installation Steps

1. Insert the CD-ROM in your CD-ROM drive.

2. Log in as superuser (root).

3. Mount the CD-ROM. For example:

/etc/mount /dev/dsk/cdrom /cdrom -t cdfs

Go to Step 4 to run the update program interactively. Go to Step 5 to run 
the update program non-interactively.

4. To install HP VEE interactively, execute the following command:

/etc/update

Then answer the update prompts as follows:

a. Select: Change Source or Destination ->

b. Select:  From Tape Device to Local System... (yes, even for 
CD-ROM)

c. Enter the file name for the update image in the Source field as 
follows:

i. For the development environment, enter:

/cdrom/HP-UX9/veetest.s700.updt

ii. For the run-time environment, enter: 

/cdrom/HP-UX9/veerun.s700.updt

d. Press the Done softkey:  f4

e. Select:  Select All Filesets on the Source Media ->

f. Select:  Start Loading Now...
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Installing HP VEE
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g. Answer Y when asked to confirm.

The update program will tell you when it is done. It will take 5-10 
minutes. Then go to Step 5.

5. To install HP VEE non-interactively, execute one of the following 
commands:

a. For the development environment, enter: 

/etc/update -s /cdrom/HP-UX9/veetest.s700.updt VEETEST

b. For the run-time environment, enter: 

/etc/update -s /cdrom/HP-UX9/veerun.s700.updt VEERUN

The update program will tell you when it is done. It will take 5-10 
minutes. Then go to Step 6.

6. Review the update log file for any error or warning messages by 
executing the following command:

view /tmp/update.log

7. Unmount the CD-ROM. For example:

/etc/umount /cdrom

Once you have completed the HP VEE software installation, you may run 
HP VEE. The next chapter has some information about this.
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Installing HP VEE on HP-UX 10
Use this section if you have Version 10.01 or 10.20 of HP-UX.

Overview 

The HP VEE installation CD-ROM contains a mountable file system. The 
HP-UX 10 installation programs expect the CD-ROM to be mounted on 
your file system. Your system must meet the following prerequisites before 
you mount the CD-ROM on your file system:

n The cdfs subsystem must be in your kernel. Use the HP-UX SAM 
program to verify the cdfs subsystem is in your kernel. If it isn’t, use 
SAM to add it.

n There must be an empty directory to use as a mount point. This example 
procedure assumes a directory called /cdrom. Your mount directory can 
have a different name. If needed, you can create this directory with the 
following command:

mkdir /cdrom

n There must be a block-mode device special file on your system for the 
CD-ROM drive. This special file may already exist in the /dev/dsk 
directory. If you do not find it there, you can create one with the mknod 
command. When using the mknod command you must supply a major 
number. Use 7 for a SCSI CD-ROM drive. The following procedure 
assumes a block-mode device special file name of /dev/dsk/cdrom. 
Your special file can have a different name.

If you are installing HP VEE on a stand-alone system, use the swinstall 
program (next section). If you are installing HP VEE on a clustered system, 
use the swcluster program (follows the next section.) For further 
information about the HP-UX installation utilities, refer to the HP-UX 
System Administration Tasks manual.
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Installing HP VEE on HP-UX 10
Installation Steps on a Stand-Alone System

To install HP VEE on a stand-alone system:

1. Insert the CD-ROM in your CD-ROM drive.

2. Log in as superuser (root).

3. Mount the CD-ROM. For example:

/etc/mount /dev/dsk/cdrom /cdrom -t cdfs

Go to Step 4 to install the software interactively. Go to Step 5 to install 
the software non-interactively.

4. To install the software interactively:

a. Execute the following command:

swinstall

b. The Specify Source dialog box appears.

In the Source Depot Path... field, enter one of the following:

i. Install the development environment:

/cdrom/HP-UX10/veetest.s700.depot

ii. Install the run-time environment:

/cdrom/HP-UX10/veerun.s700.depot

then click on OK.
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c. The SD Install-Software Selection dialog box appears listing 
the product bundle (check this against your media package; for 
example, E2111F).

i. Click on the product name in the list field to highlight the bundle.

ii. Click on Actions ⇒ Mark For Install to select the HP VEE 
bundle for installation.

iii. Click on Actions ⇒ Install (analysis)... to begin the 
analysis process.

iv. The Install Analysis dialog box appears. The analysis 
ensures the process will be successful. The analysis status reads 
Ready if there are no problems. If the analysis fails, click on the 
Logfile button for information.

v. When the analysis status reads Ready, click on OK to start the 
installation.

d. The Install Window dialog box appears indicating the installation 
status. The HP VEE software is installed when the Complete field 
displays 100%. This will take about 5-10 minutes.

i. If the program prompts you about problems, click on the Logfile 
button for information.

ii. Click on Done to return to the SD Install-Software 
Selection dialog box. 

e. Click on File ⇒ Exit.

f. Go to Step 6.
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5. To install the software non-interactively:

a. Execute one of the following commands:

i. Install the development environment:

swinstall -s /cdrom/HP-UX10/veetest.s700.depot VEETEST

ii. Install the run-time environment:

swinstall -s /cdrom/HP-UX10/veerun.s700.depot VEERUN

b. The swinstall program tells you when it’s done. Installation takes 
about 5-10 minutes.

c. To check for errors or warnings that might have occurred during 
installation, you can review the logfile using the following command:

view /var/adm/sw/swagent.log

d. Go to Step 6.

6. Unmount the CD-ROM. For example:

/etc/umount /cdrom

Once you have completed the HP VEE software installation, you may run 
HP VEE. The next chapter has some information about this.
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Installation Steps on a Clustered System   

1. Insert the CD-ROM in your CD-ROM drive.

2. Log in as superuser (root).

3. Mount the CD-ROM. For example:

/etc/mount /dev/dsk/cdrom /cdrom -t cdfs

4. Run the swcluster program using verbose mode:

swcluster -i -vvv

5. The Select Alternate Root Path dialog box appears. Click on OK 
to accept the current entries.

6. The Specify Source dialog box appears.

a. In the Source Depot Path... field, enter

/cdrom/HP-UX10/veetest.s700.depot

b. Click on OK.

7. The SD Install-Software Selection dialog box appears listing the 
product bundle (check this against your media package; for example, 
E2111F).

a. Click on the product name in the list field to highlight the bundle.

b. Click on Actions ⇒ Mark For Install to select the HP VEE 
bundle for installation.

c. Click on Actions ⇒ Install (analysis)... to begin the 
analysis process.
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8. The Install Analysis dialog box appears. The analysis ensures the 
process will be successful. The analysis status reads Ready if there are 
no problems. If the analysis fails, click on the Logfile button for 
information.

a. When the analysis status reads Ready, click on OK to start the 
installation.

b. A Confirmation dialog box appears. Click on Yes to start the 
installation.

Now, the windows that were opened while running swcluster will 
close and further processing will occur with log messages going to the 
terminal window from which you started swcluster. Installation 
time varies depending on the number of clients on the cluster. This is 
typically 15-20 minutes.

9. To review the logfile for error or warning messages that might have 
occurred during installation, execute the following command:

view /var/adm/sw/swagent.log

10.Unmount the CD-ROM. For example:

/etc/umount /cdrom

Once you have completed the HP VEE software installation, you may run 
HP VEE. The next chapter has some information about this.
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After You Have Installed HP VEE

Once you have finished installing HP VEE, verify the installation and 
perform other tasks as they pertain to your system and situation.
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Verifying the Installation
Start HP VEE as follows:

1. Log onto HP-UX, and start X11 (or HP VUE) if they are not already 
running.

2. At the prompt in an active X11 or HP VUE window, type:

veetest

If you move HP VEE to a non-default directory, you must start HP VEE 
using the command veetest -d /MySpecialDir.

Shortly, you’ll see the HP VEE window. 

The Getting Started with HP VEE manual, which shipped with your product, 
has a complete description of the HP VEE window, the parts of the window, 
how to start and stop HP VEE, and how to develop simple HP VEE 
programs. If you are unfamiliar with HP VEE, you should begin with this 
manual.

To exit HP VEE, click on File, then click on Exit in the resulting pull-
down menu. The HP VEE window disappears.
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Where to Go from Here
Once you have installed HP VEE, you can get information as follows. Be 
aware that much of the information is online. Again, the Getting Started with 
HP VEE manual has a complete description of how to get additional 
information. 

n Descriptions about what is new in this release of HP VEE, and how to 
use HP VEE are located in the online help:

q In the HP VEE menu bar, click on Help.

q Select Contents and Index and click.

q You get a list of help areas; for example, What’s New in HP VEE , 
How Do I... , Tell Me About... , and Reference . Double-click 
on an area to get more information or topics.

n The back covers of manuals contain a guide to using shortcuts in the 
HP VEE window.

n The HP VEE Advanced Programming Techniques manual has 
information as per title.

n The Controlling Instruments with HP VEE manual explains how to make 
HP VEE interact with instruments.
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Additional Information for Programmers
The following sections provide information of interest to HP VEE 
programmers.

About the .veeio File

HP VEE contains a file called /usr/lib/veetest/config/d.veeio on 
HP-UX 9, and /opt/veetest/config/d.veeio on HP-UX 10. This 
ASCII file contains some example configuration information (for example, 
hardware type and addresses) for communicating with external instruments. 
As shipped, it contains several entries that are used to run some of the 
programs in the examples directory. 

The first time each user runs HP VEE, HP VEE automatically copies the 
d.veeio file to that user’s $HOME directory as .veeio. There is nothing 
that you, the system administrator, need to do to configure the .veeio file. 
Users will add to this file as they configure additional drivers.
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Color Planes and HP VEE

Your computer is equipped with a certain number of display planes (usually 
1, 4, 6, or 8). X11 uses the information in these display planes to color your 
application’s window. If you have more than one application running (each 
in its own window), and you notice the screen colors changing as you move 
from one application’s window to another, then one of two things may be 
happening. Either all the applications, together, use more colors than one set 
of planes can handle, or one or more of the applications allocates its own 
private color map (for example, HP BASIC/UX).

HP VEE uses at least 100 colors (this varies depending which colors your 
program actually uses), so you may experience this behavior when HP VEE 
is one of your applications. The symptoms are: when you are in the HP VEE 
window, the HP VEE colors will be correct for HP VEE, but may be wrong 
in other application’s windows. When you move to another application’s 
window, the colors will be correct for that application, but may be wrong for 
HP VEE. This is typical X11 behavior -- it is not a problem with HP VEE.

For further information, refer to the "Configuring HP VEE" appendix in 
HP VEE Advanced Programming Techniques manual.

Local-Language Keyboard Support in HP VEE

You can configure HP VEE to accept input from local-language keyboards 
and to display most local-language characters. If your users will run HP VEE 
on a system that has a non-USASCII keyboard, you must configure HP VEE 
to support the local language keyboard before your users use HP VEE. 
Please refer to the "Configuring HP VEE" appendix in HP VEE Advanced 
Programming Techniques. This appendix includes information on supported 
keyboards and how to configure HP VEE for those keyboards.
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Help Viewer

The Help viewer used for this version of HP VEE affects how certain 
environment variables are set. It also affects the printer configuration for 
printing Help information.

Environment 
Variables

Specific environment variables are set when you run HP VEE so the Help 
viewer will run correctly on your system. HP VEE sets the value for the 
HHHOME environment variable to the default installation directory. There is 
no environment variable that you can set that lets you find the Help viewer if 
you move HP VEE to a non-default directory.

If you move HP VEE to a non-default directory, you must start HP VEE 
with the command veetest -d /mySpecialDir.

The following table lists the variables set for the Help viewer and their 
values: 

Environment 
Variable

Value Used For

HHHOME ~installDir
(default directory is
/opt/veetest in HP-UX 10,
/usr/lib/veetest in HP-UX 9)

This directory contains the Help 
viewer executable, and the HP VEE 
online help file.

XPPATH ~installDir/xprinter
(default directory is
/opt/veetest in HP-UX 10,
/usr/lib/veetest in HP-UX 9)

The Help viewer looks here to find 
the configuration files it uses when 
you use the Help viewer’s

File ⇒ Print command.
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Printing Help Viewer 
Contents

To print HP VEE Help viewer contents to a printer, you must first configure 
the printer. The following procedure creates a .Xpdefaults file in your 
home directory so that you only need to configure a printer once. It is vital 
that you click on Save before and after configuring your new printer as 
stated in the procedure.

1. If the Help window is not open, click on Help ⇒ Contents and 
Index in HP VEE.

2. In the Help window, click on File ⇒ Printer Setup and immediately 
click on Save.

3. Change the Output to box to Printer.

4. Click on Install and then click on Add Printer.

5. Highlight the desired printer and click on Define New Port.

6. Select the port, or click on Spooler to add a new port. Click on 
Dismiss when you are done.

7. Highlight the desired port and click on Add Selected.

8. Click on Dismiss until you exit.

9. Click on Options to change printers.

10.Click on Save to update the .Xpdefaults file with your changes.

11.Click on Apply to have your changes take immediate effect and close the 
dialog box.

The printer is now configured. 
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