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Preface This manual is written for engineers and scientists who

have minimal programming experience. It assumes some

knowledge of HP-UX. It does not assume any knowledge

of HP VEE-Test, HP VEE-Engine, or X Window system

(X11).

About This Manual. This guide contains simple,

hands-on exercises which quickly show you how to work

within HP VEE and create HP VEE models. It contains

information for both the HP VEE-Engine and the HP

VEE-Test products. Any di«erences between the use of

the products are noted in the text.

To best learn how to use HP VEE, follow this manual

sequentially, from Chapter 1 to Chapter 4, and complete

all exercises. You will need two or three hours to

complete all the exercises in this guide. However, you

can do these exercises at your own pace, and you can

stop at any time for breaks.
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This manual is structured as follows:

Content of this Manual

Chapter Summary

1:\Introduction" An introduction to HP VEE, its

interface, and some HP VEE

concepts.

2:\Interacting with

HP VEE"

An introduction to the basic

interactioin techniques you need

to work within HP VEE.

3:\Creating Models" An introduction to building and

running models in HP VEE.

4:\Exploring Instruments

in HP VEE-Test"

An introduction to con¬guring

and communicating with

instruments with HP VEE-Test.

5:\Common Problems" A listing of some common

problems and rescue procedures.

Glossary

Index

After you've completed the exercises in this manual,

you'll know how to work with HP VEE menus, select

and operate on graphical objects, and create and run

simple models. These skills will let you start using HP

VEE to build your own models. The exercises, however,

cover only a subset of HP VEE's functionality. For

complete descriptions of all the HP VEE features, please

refer to the Using HP VEE and HP VEE Reference

manuals.
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Conventions Used

in this Manual

This manual uses the following typographical

conventions:

Example Represents

Installing HP VEE Italicized words are used for book titles

and for emphasis.

File Computer font represents text you will

see on the screen, including menu

names, features, or text you have to

enter.

cat ¬lename In this context, the word in computer

font represents text you type exactly as

shown, and the italicized word

represents an argument that you must

replace with an actual value.

File =) Open Features separated with the arrow

indicate the order of selection from a

menu.

Zoom Out | In 2x

| In 5x

Choices in computer font, separated

with a bar (|), indicates that you

should choose one of the options.

•Return¶ The keycap font graphically represents a

key on the workstation's keyboard.

Press •Ctrl-O¶ Dash-separated keys represent a

combination of keys on the

workstation's keyboard that you should

press at the same time.

Dialog Box Bold font indicates the ¬rst instance of

a word de¬ned in the glossary.
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Introduction

What is HP VEE? Welcome to HP's visual engineering environment, the

\programming-less" application for engineering problem

solving. HP's visual engineering environment includes

both HP VEE-Test and HP VEE-Engine, collectively

referred to in this manual as HP VEE. HP VEE

gives you the ability to gather, analyze, and display

data without programming. HP VEE increases your

productivity by shortening the time it takes you to solve

engineering problems.

The HP VEE family includes two separate products:

HP VEE-Engine

Designed for the engineer and scientist. It allows you

to analyze and display data stored in a ¬le, input by

the user, or generated mathematically.

HP VEE-Test

Designed for the test and measurement professional. It

includes everything in HP VEE-Engine, plus it allows

you to communicate visually with instruments.
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What Are

Models?

Before you begin the exercises in this manual, please

take a moment to become familiar with the fundamental

basis of HP VEE: models.

Models are a method of solving engineering problems.

As an engineer or scientist, you might often model your

problems with block diagrams. In the past, once you

had modeled your problem, you then needed to write a

computer program to re-create the model represented in

the block diagram. Now, with HP VEE, you can lay out

the block diagram by selecting and placing graphical

objects on the screen and connecting them with lines.

Together, the connected objects represent the model for

a particular engineering application.

In HP VEE, you build, modify, and run models by

selecting from menus and manipulating objects|without

ever writing a single line of programming code! This

lets you spend more time concentrating on solving your

engineering problems.

Example Model The next two ¬gures show ¬rst the detail view, then the

panel view, of a Lissajous model.
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The detail view is where you enter and modify your

model.

Figure 1-1. Example Model, Detail View
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The panel view is the view of a model in HP VEE that

shows only those objects needed to run the model and

view the resultant data.

Figure 1-2. Example Model, Panel View
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Ready to Begin? There are a few prerequisites for the exercises in this

guide:

You must be running the X Window System (X11) on

HP-UX.

HP VEE must be installed. If HP VEE is not

installed, your system administrator should follow

the instructions in the Installing HP VEE manual to

install HP VEE on your system.

You must know HP-UX basics. This guide assumes

you know how to perform simple operations with

the HP-UX operating system, such as logging in

and out and working with ¬les and directories. If

you don't know how to do these tasks, ask your

system administrator or refer to the manual titled

A Beginner's Guide to HP-UX to learn these

operations.

You must know how to start X11. This may happen

automatically when you log in. If you're not sure, ask

your system administrator.

Note Although you're not required to have extensive HP-UX

or X11 knowledge to use HP VEE, the more you know

about HP-UX and X11, the more you can accomplish

with HP VEE.

To learn more about HP-UX or X11, refer to the

following manuals: A Beginner's Guide to HP-UX and

A Beginner's Guide to the X Window System.

Now turn to Chapter 2.
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Interacting with HP VEE

This chapter contains seven exercises which teach you

the basic interaction techniques you need to work with

HP's visual engineering environment (HP VEE):

1. \Starting HP VEE"

2. \Using Your Mouse in HP VEE"

3. \Opening Menus and Selecting Features"

4. \Manipulating Objects"

5. \Working with Open Views"

6. \Building a Simple Model"

7. \Saving Your Work and Exiting HP VEE"

The best way to learn HP VEE is to interact with HP

VEE. These exercises take you through parts of HP VEE

and teach you basic principles used to interact with HP

VEE. At certain points you will complete tasks without

step-by-step instructions through \On Your Own"

exercises.

It should take you about one hour to complete all the

exercises in this chapter.
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2
What If You

Need to Stop?

If you need to stop during the exercises to take a break

or leave work for the day, you have two choices. If

you will take only a short break, complete your latest

exercise and leave the system in its current state. When

you return, you can simply continue where you left o«.

However, if you will take a long break or you need to

leave for the day, you may want to exit HP VEE and log

o« of your system. If you need to exit HP VEE before

¬nishing the exercises, come back to this section and

follow the instructions below.

Exiting HP VEE To exit HP VEE before you've ¬nished the exercises,

follow these steps:

1. Save any current work you have in the HP VEE

window to a ¬le, as follows:

a. From the File menu, select Save As.

A dialog box appears, where you can specify the

¬le to which you can save the current work.

b. Type a unique ¬lename into the entry ¬eld at

the bottom of the dialog box. For example, you

could use the ¬lename temporary. Then press the

•Return¶ key on the keyboard (or click the OK button

with the mouse).

The current work in the HP VEE window is saved

to that ¬le.

2. From the File menu, select Exit.

You exit HP VEE, and the HP VEE window

disappears.

3. You may now exit from X11 and log out of your

system if you wish.
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2To Continue with the

Exercises

When you want to continue where you left o« in the

exercises, do the following:

1. Log in to your system (if you're not already) and

start HP VEE. For more speci¬c procedures, see

Exercise 1 in this chapter.

2. From the File menu, select Open.

A dialog box appears, which lists the ¬les you can

choose to open.

3. Type the ¬lename that you used to save the work

you had completed before you exited (for example,

temporary). Then press •Return¶ (or click on OK with

the mouse).

Your work appears in the HP VEE window again.

You may now continue where you left o« in the

exercises.

What If You

Have Problems?

If you have any problems while doing these exercises,

please refer to Chapter 5: \Common Problems".

Chapter 5 lists the problems you are most likely to

encounter while doing these exercises and how you can

recover from them.

If you do not understand a term or phrase used in the

exercises, please refer to the Glossary located at the back

of this guide.
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Exercise 1:

Starting HP VEE

First, you need to be logged in to HP-UX and have X11

started. If you're not sure how to log in or start X11,

refer to A Beginner's Guide to HP-UX or A Beginner's

Guide to the X Window System. Then start HP VEE, as

follows:

1. Move your mouse so that the pointer on the screen

moves into one of the X terminal windows. If your

window border changes color, it is activated and you

can go to the next step. Otherwise, click (press and

release) the left mouse button to activate the window

(the window border will change color).

2. At the prompt in the window, start HP VEE.

If you are using HP VEE-Test, type:

veetest •Return¶

If you are using HP VEE-Engine, type:

veeengine •Return¶

After a few seconds you'll see the HP VEE window

open, as shown in Figure 2-1. Notice the di«erent

areas of the HP VEE window.

Figure 2-1. Areas in the HP VEE Window
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Exercise 2:

Using Your Mouse

in HP VEE

You can use either a 2- or 3-button mouse with

HP VEE. This short exercise shows you how to position

and move your mouse.

If you have used a mouse before, you can skip this

exercise and go on to Exercise 3: \Opening Menus and

Selecting Features".

1. First, if you are right-handed, place your mouse on

the desk to the right of your keyboard; if you are

left-handed, place it to the left of the keyboard.

Position your mouse as shown here, with the cable

leading away from you.

Figure 2-2. Positioning the Mouse

2. Rest the palm of your hand on the hump, with

your index and middle ¬ngers on the left and right

buttons. If you have a three-button mouse, you won't

use the middle button.

3. Now move the mouse over the surface of your desk

and notice how the crosshairs (the pointer shaped

like a plus-sign) in the HP VEE window moves

accordingly.
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4. Try picking up the mouse and moving it around in

the air. As you see, the crosshairs remain in the same

position in the window when you do this. Therefore

when you need to reposition the mouse on your mouse

pad or desk, you can lift it up without changing the

position of the pointer on the screen.

Exercise 3:

Opening Menus

and Selecting

Features

This exercise shows you how to select features from

menus.

1. Move your mouse so the crosshairs are located on top

of the File menu title in the menu bar at the top of

the HP VEE window.

2. Click (press and release) the left mouse button

to open the File pull-down menu, as shown in

Figure 2-3.

Note You will use the left mouse button to make most of

the selections needed to complete the exercises in this

manual. There will be explicit instructions in those

instances when you will need to use the right mouse

button. The left button selects menu features or objects;

the right button pops up menus as a shortcut.
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Figure 2-3. The File Pull-Down Menu

The items listed in this menu are ¬le-related and

con¬guration features. Notice that the crosshairs

have now turned into an arrow. Move the arrow up

and down and notice that menu features become

highlighted. You can select, or choose, features that

highlight.

Please do not select any features (by clicking on

them) from this or any other menu right now.

Note Notice that you can't highlight Save Objects or Secure.

These features are grayed to indicate that you cannot

select them now.

Interacting with HP VEE 2-7



2 3. Move the arrow horizontally across the menu bar over

the other menu titles (Edit, Flow, and so forth).

Notice that the other menus open. Take some time

to become familiar with the features available in each

menu.

4. Move the arrow outside the current pull-down menu,

so that the arrow is in an empty area of the work

area. Then click (press and release) the left mouse

button.

You have closed the menu. If you ever open a menu

by accident and do not wish to select any feature

from it, simply move the arrow into a blank area in

the work area and click the left mouse button.

5. Open the Flow menu. Notice that the Repeat menu

feature has an arrow on the right. That arrow

indicates that there is a cascading menu o« of that

feature.

Move the arrow pointer down the Flow menu and to

the right of the Repeat feature, so that the pointer

moves on top of the arrow to the right of Repeat.

You do not need to click any mouse button.

A cascading menu appears, as shown in Figure 2-4.
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Figure 2-4. The Repeat Feature's Cascading Menu

6. Close the cascading menu and the Flow menu. To do

this, move the arrow outside both the menus into the

work area and click the mouse button.

7. Open the Help menu by positioning the crosshairs on

the menu bar over Help and clicking. Notice that

the features have ellipses ( . . . ) on the right. The

ellipses indicate that you'll get a dialog box when you

choose that feature. A dialog box is a window that is

displayed when HP VEE requires information from

you before it can continue.
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8. Click on On Features. You get a dialog box that

displays the terms that are described in On Features.

This particular type of dialog box is called a list box

because it presents a list of choices. At the bottom of

the list box there are two buttons. All dialog boxes

have buttons to accept actions and to cancel the

dialog box.

Figure 2-5. On Features Dialog Box

9. Click on the End Help button to leave the help

facility.

Once you select a Help feature, you can leave it on the

screen while working with other objects. This allows

you to read online help information while creating your

models.
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2On Your Own Explore the Help facility.

From the Help menu select Glossary.

In the list box, click on the word Button and click

on the Open Topic button (as a shortcut, you can

double-click on the word Button).

Press the Next and Prev buttons to look at other

de¬nitions.

Select another topic from the list box.

When you're ¬nished browsing through the Glossary,

click on End Help to exit Help.

Now that you know the basics about opening menus and

selecting features in HP VEE, you are ready to start

working with HP VEE objects in the next exercise.
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Exercise 4:

Manipulating

Objects

Objects are the graphical building blocks of models. In

HP VEE, objects represent a number of di«erent things,

such as math functions, controls, and displays.

This exercise shows you the basic techniques for

interacting with objects: placing them in the work area,

as well as deleting, moving, and sizing them.

1. From the Flow menu, select Start.

You see a small outline box that represents the Start

object.

2. Move your mouse to move the outline box to any

position you wish within the work area, then click the

left mouse button.

The object for the Start feature appears on the

screen. Notice that this object looks like a real-life

button you can press.

Figure 2-6. The Start Object

Click on the word Start and you will see it depress

and raise like a real button. Once you click on the

object it becomes shadowed, which indicates that it

has been selected.

To deselect it, click on the empty work area.

Deleting and

Recovering Objects

Before you do anything else with objects, you should

learn how to delete, or remove, them. That way, if you

ever select an object by mistake and need to delete it,

you will know how. To delete the Start object from the

work area:

1. Position the crosshairs over the Start object.
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2. Click the right mouse button. You'll see a menu pop

up, as shown in Figure 2-7. This menu is called the

object menu. The object menu contains a set of

features that operate on that object. Every object has

an object menu.

Figure 2-7. The Object Menu

3. Select Cut by moving the pointer down the menu

until Cut is highlighted and then clicking the left

mouse button. Note that this is the same way you

select features from the menu bar menus.

The object is removed from the work area.

If you ever remove an object by mistake, you can recover

it easily. Try this:

1. Open the Edit menu.

2. Select Paste.

The outline of the Start object appears. Place it on

the work area in the same way you did before.
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2 Using the Pop-up Edit

Menu

A shorthand method of accessing the Edit menu is to

use the pop-up Edit menu. The pop-up Edit menu

allows you to access all the various editing features more

easily when you are interacting with objects in the work

area.

1. Click on an empty area in the work area to deselect

any objects.

2. Position the pointer over an empty space in the work

area and click the right mouse button. Notice that

you get a pop-up Edit menu. This is exactly the

same menu as the Edit menu that you can pull down

from the menu bar.

Figure 2-8. Pop-up Edit Menu

3. Close this pop-up menu without selecting from it by

moving the arrow pointer into the work area and

clicking the mouse button (just as with pull-down

menus).
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2Moving and Sizing

Objects

Once you have an object in the work area, you often

need to move the object or make the object larger or

smaller. These actions help you manage the available

work area space.

1. Position the pointer over the Start object and click

the right mouse button to get the object menu.

2. Select Move from the object menu. Notice that the

pointer changes.

3. Press and continue to hold the mouse button down.

While holding the mouse button down, move the

mouse around. This action is called dragging. As you

drag the pointer around, notice that an outline of the

object moves.

Figure 2-9. Moving an Object

4. Release the mouse button and the Start object

moves to where you placed the outline.

5. To move the object another way, position the pointer

at the edge of the Start object, then drag the object

(press and continue to hold the mouse button down).

This is a shortcut method of moving the object

without accessing the object menu.

6. Select Size from the object menu. Notice that the

pointer changes.

Interacting with HP VEE 2-15



2
7. Press and hold the mouse button down. Drag the

pointer around and notice that the outline of the

object stretches.

Figure 2-10. Sizing an Object

8. Release the mouse button and the object resizes to

the size of the stretched outline.

On Your Own

Try using the other features on the object menu and see

what they do.

Create many Start objects by using the Clone

feature.

Create a description of the Start object by selecting

Show Description, clicking in the center area of the

description box, and typing a description (such as

This is a Start object). Note that it scrolls if you

type beyond the right margin or below the bottom

margin. It does not automatically wrap to the next

line. When you are ¬nished, click on OK.

Click on the object menu's Help feature to read about

using the Start object.

Please do not select the Terminals feature from the

object menu right now.
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2Manipulating Multiple

Objects

Now that you know how to manipulate a single object,

you can learn how to manipulate a group of objects. For

example, instead of moving objects individually, you can

move them as a group.

Make sure you have several Start objects on your work

area.

1. From the Edit menu, select Select Objects. Notice

the following message is displayed on the HP VEE

title bar: Select desired objects.

Figure 2-11. Multiple Object Selection Message

2. Follow the message instructions by clicking on several

of the Start objects that you created. Each will

highlight.

3. Click on an empty area in the work area to end

Select mode.

4. From the Edit menu, select Move Objects. An

outline box appears that represents the set of Start

objects you selected.
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Figure 2-12. Multiple Object Move

5. With the left mouse button, drag the outline box to

any position within the work area. Release the left

mouse button to place the group of objects.

On Your Own

Explore other multiple object manipulations. Use the

pop-up Edit menu.

Select a group of objects and Cut them. (Remember to

use the multiple Select from the Edit menu.) Now

Paste them back. Now Paste again.

Select a group of objects and Copy them. Now Paste

them.

Make sure you leave at least one Start object on the

work area before continuing to the next task.
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2Moving the Work Area You can also move the work area itself which will, in

turn, move the objects placed on the work area. This is

helpful when you run out of space on the visible work

area and need more space to place more objects, or when

an object is initially placed so that some part of it is

hidden past the border of the work area. There are two

ways to move the work area:

1. Moving the work area by scrolling.

The bottom and right borders of the HP VEE window

contain the scroll bar.

Figure 2-13. Scroll Areas

Move the crosshairs over any one of the arrows in the

scroll bar. These arrows are scroll arrows. Press and

continue to hold down the left mouse button without

moving the crosshairs, then release the mouse button.

Now drag the bar on the side of the window up and

down. This bar is called the scroll slider.
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While you hold down the mouse button on the arrow

or drag the scroll slider, the view of the work area

moves in the direction of the arrow. This means that

the work area moves in the opposite direction of the

arrow.

If you wish, try each of the arrows in the borders

to get a feel for moving the work area. If you get

confused and can not see where your objects are, click

in the center of each scroll slider and the objects will

re-appear.

2. Moving the work area directly.

The most direct way to move the work area is to

position the crosshairs over any empty space in the

work area and drag the crosshairs in any direction.

Again, the work area moves accordingly.
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Area

The last part of this exercise clears the work area in

preparation for your next set of tasks.

From the File menu, select New. Answer the dialog box

you get by clicking on the Clear (don't save) button.

Figure 2-14. Clearing the Work Area

This action removes all objects from your work area and

gives you a new, empty work area.

You now have learned how to interact with objects. The

next exercise shows you how to work with the open

views of objects.
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Exercise 5:

Working with

Open Views

HP VEE can display every object as either an icon or as

an open view. An icon is the small representation of the

object. An open view is the expanded representation of

the object, which shows the details of the object.

Exploring an Open

View

Some objects in HP VEE are ¬rst displayed as open

views, and some as icons. In this exercise you will learn

how to open an icon, then minimize it again.

1. From the Device menu, to the Virtual Source

cascading menu, select Function Generator and

place it in the work area. It is displayed as an open

view.

Notice the di«erent parts of the title bar of the open

view as shown in Figure 2-15.

Figure 2-15. Open View Title Bar
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2. Change the name of the Function Generator object

by clicking on the words Function Generator in

the open view's title bar, typing Example Function

Generator, and pressing •Return¶. Notice that the area

you typed in looks recessed. HP VEE lets you know

where you can type information by showing a recessed

rectangle.

3. Click on the minimize button which is located in

the upper right corner of the open view's title bar.

This action turns the open view into the icon (the

minimized view). Notice that the name of the icon is

also Example Function Generator. You can change

the title of any object to something that has more

meaning for you.

Figure 2-16. An Icon Replaces the Open View
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4. Open the Function Generator icon by positioning

the pointer on the icon and clicking twice in rapid

succession (this action is called double-clicking).

5. Move the pointer to the Function ¬eld. Click on

Cosine. You will see a list box of choices.

Figure 2-17. List Box

6. Set Function to a square wave by double-clicking on

Square.
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Terminals

To connect objects, you will draw lines between the

objects. The \connection points" are input and output

pins.

Figure 2-18. Input and Output Pins

There can be pins on the top, bottom, left, and right

of objects. These are called the sequence input pin,

sequence output pin, data input pin, and data output

pin, respectively. You connect sequence input and

output pins with lines create a speci¬c sequence of

operation in your models. You connect data input and

output pins to carry data between objects.

Input terminals and output terminals are the open

view's representation of input and output pins|they

display information about the pin. To change terminal

information, you will use the Terminals feature from the

object menu.
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In the following exercise you will add a data input and

explore some of the features of data inputs.

1. Open the Example Function Generator object menu.

To open the object menu from the open view, click on

the object menu button, which is located in the upper

left corner of the open view's title bar. You can also

pop up the object menu by clicking the right mouse

button when the pointer is positioned over the object.

2. From the Example Function Generator object menu,

to the Terminals cascading menu, select the Add

Data Input feature.

3. Double-click on Amplitude. You will now see a

new data input terminal, labeled Amplitude, in the

Example Function Generator.

4. Double-click on the Amplitude input terminal. The

dialog box you now see lists the input terminal

information.

Figure 2-19. Terminal Information

Notice that the ¬eld after Name looks recessed,

which means you can change the name of the input
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terminal. If there is any data at this terminal, it will

be listed under the words Container Information.

5. Click on the Cancel button on the Input Terminal

Information dialog box.

6. Click on the minimize button to close the open view.

On Your Own Explore the open view of the Function Generator.

Open Example Function Generator.

Add a Frequency data input terminal.

Change the name of the Frequency input.

Delete the Frequency input.

Click on Show Terminals from the cascading

Terminals menu. Select Show Terminals again.

Notice that the checkmark in the Show Terminals

check box indicates that the object's terminals are

displayed.

Do not delete the Example Function Generator from

the work area, as you will use this object in the next

exercise.
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Exercise 6:

Building a Simple

Model

In this exercise, you will learn how to connect objects

together to form a simple model and to add and use data

input controls.

1. Verify that you have the Example Function

Generator object from the previous exercise in your

work area. If you do not, work through Exercise 5

again. When you build your model in this exercise,

you will use the Amplitude input terminal you added

to the function generator in Exercise 5.

2. Place the function generator to the left of the work

area and minimize it (click on the minimize button).

3. From the Display menu, select Waveform (Time).

4. Place the display to the right of the Example

Function Generator object in the work area.

Notice that Displays are initially displayed as open

views because you'll usually want to use them in their

open views.
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Figure 2-20. Unconnected Objects

Connecting Objects Notice the data output pin on the right side of the

Example Function Generator and the data input pin on

the left side of the Waveform (Time). In HP VEE, data

­ows from left to right through an object, so pins on the

left side of an object are data input pins and those on

the right side are data output pins.

Follow these steps to connect the Example Function

Generator's data output pin to the Waveform (Time)'s

data input pin.

1. Move the crosshairs close to the output pin on the

right side of the Example Function Generator. The

crosshairs should still be over the work area, not

within the border of the object. Then click the left

mouse button.

Notice the little box that appears over the crosshairs.

This box indicates that you are in line drawing mode.
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In line drawing mode, the line follows the box around

the work area when you move the mouse.

If you do not see the line and the little box, you may

have clicked on the wrong place. Try again.

2. Move the crosshairs over an empty area of the work

area and double-click. Note that the line disappears.

If you ever click close to a pin by mistake and start

the beginning of a line, you can exit line drawing

mode by double-clicking in this way.

3. Start the line again from the right, output pin of the

Example Function Generator.

4. Move the box close to the input pin on the left of the

Waveform (Time) display, and the box will \jump" to

the pin on the display.

5. Once the box jumps to the display's pin, click the left

mouse button to complete connecting the line between

the two objects.
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Controls to Your

Model

In this exercise you will use an object called a slider

to specify the amplitude to the Example Function

Generator in your model.

1. From the Data menu, click on Real Slider and place

the slider above or to the left of Example Function

Generator. You may need to enlarge the size of your

HP VEE window or move the objects within the work

area to make room for the slider.

Figure 2-21. A Real Slider

2. Move the pointer to the maximum value ¬eld. Click

on this ¬eld and type 5.

3. You can change the value of the slider in two ways:

a. Move the pointer over the white slider control. By

dragging the left mouse button, move the slider

control up and down. Note that the readout ¬eld

indicates the new value. Release the mouse button

to set the new value.

b. Click over the readout ¬eld, type 1, and press

•Return¶.

Notice that the slider control moves to indicate the

position of 1, as you speci¬ed in the readout ¬eld.
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4. Connect the Real Slider data output pin to the

Example Function Generator's data input pin.

Figure 2-22.

Connected Model Using Real Slider as an Input
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2Running the Model You have just built your ¬rst, simple model by

connecting the objects together. Now you can run the

model to see the results.

1. Click on the Run button at the top right of the

HP VEE window.

The Waveform (Time) display shows the waveform

that was created by the function generator.

Figure 2-23. A Simple Model After It Was Run
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Between Objects

Before you continue, you need to know how to delete

lines between objects.

1. From the Edit menu, select Delete Line. Notice the

prompt displayed on the title bar.

2. Click the pointer on or near the line between Example

Function Generator and Waveform (Time) display.

The line disappears.

Now you know how to delete lines between objects.

Before you continue, reconnect Example Function

Generator and Waveform (Time).

On Your Own

Clear the Waveform (Time) display. Hint: use the

object menu.

Change the Example Function Generator frequency

to 500. Hint: open the Example Function Generator

object.

Change the Amplitude to 5.

Run the model.

Press the AutoScale button on the Waveform (Time)

display to automatically scale the display to the

waveform amplitude.

Add a Start to your model and connect its bottom,

sequence output pin to the top, sequence input pin on

the Example Function Generator. Run your model by

pressing the Start object.
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Exercise 7:

Saving Your Work

and Exiting HP

VEE

This short exercise shows you how to save the work

you did in Exercise 6, which is the same procedure you

should follow to save any model for the ¬rst time. Since

this is the ¬nal exercise in this chapter, this exercise then

shows you how to exit HP VEE as well.

To save your work and exit HP VEE, do the following:

1. From the File menu, select Save As.

A dialog box appears, in which you specify the ¬le

where you want to save the current work.

2. The cursor is automatically placed on the entry ¬eld

at the bottom of the dialog box, awaiting your input.

Type the ¬lename model1, then either click on the OK

button or press the •Return¶ key.

The model in the HP VEE window is saved to that

¬le.

Figure 2-24. Save Dialog Box
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get in the habit of saving your work on a regular basis.

After doing an initial Save As, periodically select Save

from the Edit menu to save your work.

3. Now, from the File menu, select Exit.

You exit HP VEE, and the HP VEE window

disappears.

Congratulations! You have now completed all the

exercises in this chapter.

Before going on to the next chapter, try the quiz on the

next page to make sure you have mastered the skills that

were taught in the last seven exercises.
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Quiz If you can complete the following tasks, you have

successfully gained the basic skills you need to interact

with HP VEE. The answers for this quiz are provided in

the next section.

In the following quiz, you will display random X and Y

data.

1. Start HP VEE again.

2. Get a Start object and place it in the work area.

3. Get an Until Break object and place it in the work

area.

4. Get two Random Number objects and place them in

the work area.

5. Get an X vs Y Plot and place it in the work area.

6. Connect the Start sequence output pin to the Until

Break sequence input pin. Connect the data output

from Until Break to the sequence inputs of both the

Random Number objects. Connect the data outputs

from the Random Number objects to the data inputs

of the X vs Y Plot.

7. Run the model for a few seconds, then stop it.

8. Clear the X vs Y Plot.

9. Change the X and Y scales of the display to be from

-1 to 2 in both the X and Y directions.

10. Change the trace color on the X vs Y Plot. Hint:

look in the X vs Y Plot's object menu.

11. Run the model for a few more seconds, then stop it.

12. Change the name in the HP VEE title bar to be

Quiz Model.

13. Save the model to the ¬lename quiz1.
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Answers to the

Quiz

Your model should look similar to the following ¬gure:

Figure 2-25. Quiz Model

1. Start HP VEE again.

Log on (if you need to). Type veeengine •Return¶ or

veetest •Return¶.

2. Get a Start object and place it in the work area.

From the Flow menu, select Start and click to place

the object in the work area.
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3. Get an Until Break object and place it in the work

area.

From the Flow menu, to the Repeat cascading menu,

select Until Break and click to place the object in the

work area.

4. Get two Random Number objects and place them in

the work area.

From the Device menu, select Random Number and

click to place the object in the work area. If you have

trouble ¬nding which menu holds the Random Number

feature, you can access Help. You can use Clone to

get the second Random Number object.

5. Get an X vs Y Plot and place it in the work area.

From the Display menu, select X vs Y Plot. Place

the object in the work area.

6. Connect the Start sequence output pin to the Until

Break sequence input pin. Connect the data output

from Until Break to the sequence inputs of both the

Random Number objects. Connect the data outputs

from the Random Number objects to the data inputs

of the X vs Y Plot.

Move the objects so that Until Break is on the left

side of the work area, Start is above Until Break,

the two Random Number objects are in the middle of

the work area, one above the other, and the X vs Y

Plot object is at the right of the work area.

Connect the sequence output pin (on the bottom) of

the Start object to the sequence input pin (on the

top) of the Until Break object. Connect the data

output pin (on the right) of the Until Break object to

the sequence input pins of both the Random Number

objects. Connect the data output pin (on the right) of

the top Random Number object to the XData input pin

(on the left) of the X vs Y Plot. Then connect the
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data output pin of the bottom Random Number object

to the YData1 input pin of the display.

7. Run the model for a few seconds, then stop it.

To run the model, click on Start To stop the model,

press the Stop button.

8. Clear the X vs Y Plot.

From the X vs Y Plot object menu, to the Clear

Control cascading menu, select Clear.

9. Change the X and Y scales of the display to be from

-1 to 2 in both the X and Y directions.

Click on the ¬elds for the display limits. Change

0 to -1 and change 1 to 2 for both the X and Y

scales. Click outside the ¬elds or press •Return¶ to stop

editing.

10. Change the trace color on the X vs Y Plot. Hint:

look in the X vs Y Plot's object menu.

From the X vs Y Plot object menu, select Traces &

Scales. In the resulting dialog box, click on Yellow,

the value in the Color ¬eld. Choose a color from the

list box of colors by clicking on the color you wish.

Click on OK.

11. Run the model for a few seconds again, then stop it.

To run the model, click on Start. To stop the model,

press the Stop button.

12. Change the name in the HP VEE title bar to be

Quiz Model.

Click on the word Untitled in the HP VEE title bar

and type Quiz Model •Return¶.

13. Save the model to the ¬lename quiz1.

From the Edit menu, select Save As. Type quiz1 in

the dialog box and click on OK or press •Return¶.
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What's Next? This is the end of the exercises to help you become

comfortable interacting with HP VEE. The next chapter

takes you through exercises that teach you more about

creating models.

If you had any problems with these tasks, please review

the exercises in this chapter before going on.
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3

Creating Models

This chapter contains six exercises which show you how

to build models:

1. \Understanding Data Flow"

2. \Using Data Files"

3. \Creating a UserObject"

4. \Creating a Panel View"

5. \Working with Data"

6. \Using HP VEE Examples"

It should take you about one hour to complete all the

exercises in this chapter.
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Exercise 1:

Understanding

Data Flow

When models run, they follow certain rules (just as

written programs do). This exercise introduces you to

some of these rules.

Note The model built in this exercise will be used in the next

three exercises. Make sure you complete this exercise

before going on to Exercise 2: \Using Data Files".

In this exercise you will use an iterator to plot ten

random numbers. If HP VEE is not running, start it

now. If you have any objects on your work area, clear

the work area by selecting New from the File menu.

1. From the Device menu, select Random Number. Place

it in the center of your work area.

2. From the Flow menu, to the Repeat cascading menu,

select For Count. Place it to the left of the work

area.

Notice that For Count is set to 10. This tells the

object to operate 10 times before it is ¬nished.

3. From the Flow menu, select Start, and place it on

the top left of your work area, above the For Count

object.

4. From the Display menu, select XY Trace. Place it

on the right of your work area.

5. Connect the Start sequence output pin to the top,

sequence input pin of For Count.

6. Connect the data output pin of For Count to the

sequence input pin on the top of Random Number.

7. Connect the data output pin of Random Number to

the data input pin of the XY Trace display.
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Figure 3-1. Plotting Random Numbers

Whenever you connect objects, you must understand

the ¬rst rule of data ­ow within the model:

Rule 1 Data ­ows from left to right through an object. This

means that on all objects with data pins, the left data

pins are inputs and the right data pins are outputs.

8. From the Edit menu, click on Show Exec Flow.

Although the menu immediately goes away, if you

bring it up again you will see that the Show Exec

Flow check box is checked, or selected.

Show Exec Flow is a feature that allows you to see

the order that objects operate by highlighting the

object that is currently operating.
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9. Click on Start. You will see each object highlight,

which indicates the object that is currently

operating.

10. Click on Auto Scale in the XY Trace so the graph

area automatically scales to include your data.

11. Turn o« the Show Exec Flow feature and run the

model again. Notice that the objects no longer

highlight.

12. Turn on Show Exec Flow again.

If you wish to see the execution ­ow explicitly, in slow

motion, press the Step button to step your way through

the model's execution.

With the ¬rst Step you will see the plot clear and an

arrow will appear that points to the Start object. The

arrow shows the next object that will execute. With

the second Step you will see Start highlight, and the

arrow will point to For Count. With the third step you

will see For Count highlight, and the arrow will point to

Random Number. Then Random Number highlights and the

arrow points to XY Trace. Then XY TRACE highlights and

the arrow points back to For Count as the ¬rst point

is plotted. And so on until all ten points have plotted.

When the model is ¬nished executing, the arrow goes

away.

As you continue stepping through the model's execution

you will notice that the For Count remains highlighted,

and therefore is operating, the entire time.

Rule 2 An object ¬nishes operating only after all appropriate

data outputs have been activated.

Before continuing with the next exercise, press the Cont

button to allow the model to ¬nish running, in case you

did not step through the entire model.
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Exercise 2:

Using Data Files

One of the powerful features of HP VEE is its ability

to easily create and read from data ¬les. The following

exercise shows how to create a data ¬le and then how to

read from the ¬le.

Writing to a File 1. Minimize For Count and decrease the size of the XY

Plot by using the Size feature from the XY Plot

object menu.

2. From the I/O menu, to the To cascading menu, select

File and place it close to the XY Trace.

3. Enter the name of the ¬le in which you wish to store

data. To do so, click on myDatafile. You will see a

list box of existing ¬lenames. To create a new ¬le,

backspace over myDatafile, and type a new ¬lename

(for example, RandomData), then click on OK.

4. Click on the check box titled Clear File At PreRun.

By default, the ¬le is created in append mode. This

means that each time you write to the ¬le, HP VEE

will add data to the end of the ¬le. In this exercise

you need to clear the ¬le each time before you write

to the ¬le. Checking the Clear File at PreRun

option changes the writing mode of the ¬le.

5. Minimize the To File object and place its icon above

the XY Trace.

6. Connect the right, data output pin from Random

Number to the left, data input pin of To File. This

means that the same data that is plotted on the XY

Trace is also written to the ¬le.

7. Click on Start. You will see a similar execution as

before, but HP VEE is writing the data to your ¬le,

in addition to plotting the data on the XY Trace.

Creating Models 3-5



3

Figure 3-2. Writing Random Numbers to a File

8. To verify the data written to the ¬le, go to another

X11 window and show the contents of the ¬le using

the HP-UX cat command: cat RandomData •Return¶.

If you do not see any data listed, verify that you are

in the same directory as the RandomData ¬le, and

verify that all your objects are properly connected.

Reading from a File You can easily read data from a ¬le. In this exercise you

will read data from a ¬le and plot the data.

1. From the I/O menu, to the From cascading menu,

select File. Place the object below the For Count.

2. Change the name of the ¬le to the same ¬le you

created in the previous section (RandomData). Notice

that RandomData is one of the ¬les in the list box that
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appears. You can select it by scrolling through the

list of ¬les and double-clicking on RandomData.

3. Click on COUNT:1, then click on the entry ¬eld to the

right of the Num Elements ¬eld, and type 10 followed

by •Return¶. This tells HP VEE to read an array of

exactly ten elements.

4. Minimize From File.

5. Connect the bottom, sequence output pin of For

Count to the top, sequence input pin of From File.

6. Clone the XY Trace and place the clone next to the

From File. Connect the data output pin from From

File to the data input pin of XY Trace. Change the

name of the display to File Data.

7. Click on Start. You should see the same plot on both

displays. If you do not, check the To File to verify

that you set it to Clear File At Prerun.

The model ¬nishes generating data and writing it to

both the To File and the XY Trace before it begins

reading the From file and plotting that data.

Rule 3 The sequence output (bottom) pin activates only after

all appropriate data outputs have activated, and even

then only after normal propagation along all standard

output lines has continued as far as possible.

8. To prepare for the next exercise, clear the XY Trace

and delete the To File, From File, and second XY

Trace (titled File Data). Notice that the lines

disappear when you delete the object.
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Exercise 3:

Creating a

UserObject

HP VEE provides a means for you to construct your own

objects, called UserObjects. A UserObject has a work

area identical to that of the main work area and it allows

you to place and connect various objects (including

other \nested" UserObjects). UserObjects also have a

user-de¬nable set of input and output pins.

A UserObject is not simply a method to help you

conserve screen \real estate". Rather, as you will see in

the following example, a UserObject is a true object

that functions under the same set of rules as any other

object such as Formula. Once created, you can use a

UserObject like any other object in terms of sizing,

moving, and operating.

In the following exercise you will create a UserObject

from objects that are already on in your HP VEE

window.

1. Select the For Count and Random Number objects.

(Remember to use Select Objects.)

2. From the Edit menu, select Create UserObject.

All the objects you've selected will be included in

the UserObject. (It will take a few seconds for your

display to change.)

Notice how the connections to the Start object

and the XY Trace are shown by input and output

terminals on the UserObject. If you cannot see the

connections you may need to move the work area.
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Figure 3-3. UserObject Example

3. In the upper right corner of the UserObject is a

square button, called the maximize button. Click on

the maximize button. The UserObject now expands

to the full size of your HP VEE window.

Use the maximize button to enlarge a UserObject

when you need to work on the details of the

UserObject, or when you have many objects in the

UserObject.

4. Click on the maximize button again. The UserObject

returns to its original size.
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5. Press Start.

Notice that the UserObject operates the For Count

ten times, then sends a single data point to the

XY Trace. This is because each output from a

UserObject is activated once and only once when

the UserObject ¬nishes operating|not each time a

UserObject output terminal is activated from within

the UserObject.

6. To capture all ten data points and then send them on

to the XY Trace, collect the ten data points into an

array, then send the array to be plotted:

a. Delete the line from Random Number to the Rand

Val output terminal of the UserObject.

b. From the Data menu, select Collector and place

it in the UserObject between Random Number and

the UserObject's data output terminal.

c. Connect the Random Number data output pin to the

Collector's top, left data input pin.

d. Connect the For Count sequence output pin to the

Collector's bottom, left input pin. This input pin

indicates to the Collector when all input data has

been input.

e. Connect the Collector data output pin to the

UserObject's output pin (Rand Val).

7. Press Start. The model now runs correctly and all

ten values are plotted.
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Figure 3-4. A Working UserObject

8. Close the UserObject by clicking on the minimize

button. Notice that it saves space and it can be easily

moved or copied like any simple object.

9. Press Start, notice that the model runs the same way

as before.
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Exercise 4:

Creating a Panel

View

HP VEE allows you to hide parts of the detailed model

from a user through a feature called a panel view. A

panel view allows you to simplify your interface and to

secure the detail view from a user if you wish. When you

create a panel view, you choose the objects from the

detail view that you want the user to see on the panel

view. These dual modes of operation allow security

and ease of use in applications where the user is not

necessarily the developer.

In this exercise you will select objects to put into the

panel view.

1. Change the name in the HP VEE title bar to be

Random Plot.

2. Select the Start and XY Trace objects.

3. From the Edit menu, select Add To Panel.

The panel view replaces your detail view. Notice that

in the menu bar, the Panel button is recessed. The

panel view should look similar to the following ¬gure.
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Figure 3-5. The Panel View

4. Press Start and notice that the model runs the same

way as before except the objects don't highlight to

show execution ­ow. Because Show Exec Flow is a

debugging tool, it highlights only in the detail view.

5. Go between the detail and the panel views by pressing

the Panel and Detail buttons.
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Securing the Panel

View

Next you will secure the panel view so that people who

use it cannot modify it. This is useful if several people

will use the model, and you wish to remain in control of

the model's functionality. Although in this exercise you

will save the detail view during the Secure step, you can

also save the model (which consists of both the detail

and the panel view) without securing the model.

1. Secure the panel view by clicking on Secure from the

File menu. HP VEE asks if you wish to save the

unsecured version.

2. Save the unsecured version by typing a ¬lename,

mod.unsec •Return¶. You should always save the

unsecured version. If you do not, you can never

modify your model again. By saving the unsecured

version, you can still make changes to the model.

HP VEE removes the Panel/Detail buttons; you can

no longer switch back to the detail view.

3. Save the secured version by selecting Save As from

the File menu, and typing mod.sec •Return¶.

On Your Own Clear the work area by selecting New from the File

menu.

Open the secured version of the model.

Open the unsecured version of the model. Go between

the panel and detail views.

Clear the work area again.
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Exercise 5:

Working with Data

This exercise explains how to use data in di«erent ways

as inputs and outputs.

Converting Data

Types

The ways that data are represented (such as in a

waveform, an array, or as a complex number) are all

very di«erent. Explicitly declaring each data type is a

complicated and tedious exercise, overshadowing many

productivity gains. HP VEE automatically converts

data as necessary so that in most cases you don't have

to be concerned about the di«erent data types and data

shapes when you're building a model.

1. From the Data menu, to the Constant cascading

menu, select Real and place it on the left side of the

work area.

2. From the Data menu, to the Constant cascading

menu, select Complex and place it below the Real.

3. From the Math menu, to the + - * / cascading menu,

select +. Place it in the middle of your work area.

4. From the Flow menu, select Start and place it

above the +.

5. From the Display menu, select AlphaNumeric and

place it on the right side of the work area.

6. Open the + object. The data input terminals are

called X Any and Y Any.

HP VEE includes a data type labeled Any that takes

any type of incoming data and attempts to convert

the data to the type the object needs or expects. If

the object cannot convert the data, a clear error

message will suggest the data type required. This is

among the most powerful features of HP VEE.

7. Minimize +.

8. Connect the objects as shown in the following ¬gure.
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Figure 3-6. Data Conversion Example

9. Click on the recessed ¬eld of the Real and type a

real value (such as 23.5).

10. In the Complex, type a complex value such as 10,5.

11. Click on Start to run the model.

HP VEE automatically converts the data as needed,

then performs the addition in the + object, then

writes the result to the AlphaNumeric.

On Your Own

Open the + object.

Double click on the X Any input terminal. You now see

a box that shows the input terminal's information,

including the actual data and data type that came in.

Add a Text to an Integer.

Clear the work area before you continue.
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Using Data Shapes HP VEE supports a variety of data shapes (such as

scalars and arrays) just as in any programming language.

Unlike most programming languages, HP VEE objects

can operate on an entire array instead of only one

element.

The following model creates a one-dimensional

ten-element array, calculates the median of the ten

values, and prints the median.

1. From the Flow menu, to the Repeat cascading menu,

select For Range. Place it on the left side of the work

area. Notice that the Thru value is 9 (by default).

Arrays are 0-based.

2. From the Flow menu, select Start and place it above

For Range.

3. From the Data menu, select Sliding Collector.

Place it to the right of For Range. Note that the

Trigger Every value is 10 (by default). This collector

creates a one-dimensional array with ten elements. It

will output the array after all ten values are input.

4. Minimize the Sliding Collector.

5. From the Adv Math menu, to the Statistics

cascading menu, select median(x). Place it to the

right of Sliding Collector.

6. From the Display menu, select AlphaNumeric. Place

it to the right of median(x).

7. Connect the data pins as shown and run the model.
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Figure 3-7. Data Shape Example

Notice that the median object operated on the entire

array at once. This is because HP VEE objects

support parallel operations.

8. Open median(x), and open the X Any data input

terminal. Under Container Information, you can see

the data that came into the object.

Now clear the work area.
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Exercise 6:

Using HP VEE

Examples

Included in the HP VEE-Engine and HP VEE-Test

products are HP VEE examples that you can use.

The examples directory has the following four

sub-directories:

applications Complete models of di«erent types of

engineering problems.

concepts Models to demonstrate general concepts

about how to use HP VEE.

demos Provided with HP Vee-Test only.

games Models that are games. Try them, they

are fun!

The following exercise shows you how to access the

example models. Before you begin, make sure your work

area is clear.

1. From the File menu, select Open. In the list box that

appears, backspace over the path in the entry ¬eld

and type the correct directory (do not press •Return¶):

If you have HP VEE-Engine, type:

/usr/lib/veeengine/examples/

If you have HP VEE-Test, type:

/usr/lib/veetest/examples/

Notice that the list box now shows the examples

sub-directories.

2. Type applications/ to see the names of the example

models in this directory. Do not press •Return¶ or you

will get an error. Notice that the ¬le names end in

.ex and .icon.

If you get the error message, click on Cancel

and bring up the Open File list box again

(File =) Open).
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3. Backspace over applications/ and type concepts/.

In this directory, example models also end in .bas

and .c. The ¬le names that end in .dat are data

¬les.

4. Return to the applications/ directory.

5. Double-click on CONTENTS. The object that appears

has scroll bars so you can scroll through the list of ¬le

names and descriptions. Read the description of each

example in this directory. If you do not see the scroll

bars of this object, enlarge your HP VEE window.

6. Clear the work area.

7. From the File menu, select Open again. HP VEE

should still be pointing to the applications example

directory.

8. Choose one of the examples by double-clicking on the

¬lename.

Look through the examples to see what you can do

in HP VEE. There is much to learn from seeing how

features are used in working examples.

9. Clear the work area.

In addition to examples, there is a libraries directory

which contains pieces of models (as objects) you can

incorporate in your models using the File =) Merge

feature. Merge lets you add outside models into the

model you currently have in your work area.
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Quiz In this quiz, you will create a model that calculates the

angular de­ection of a round shaft.

1. Place a Start at the top left of your work area.

2. Place an Real constant below Start. Change the

name to be Length, in. Type in a value of 10.

3. Place 3 more Real constants below Length, in.,

and name them and set values, from top to bottom,

Diameter, in. (value of 1), Torque, in-lb. (value

of 2500), and Shear Modulus, psi (value of 12M).

4. Place a Formula object to the right of the integer

objects. Edit the formula as follows:

a. Add data input terminals so you have 4, and

label them, from top to bottom: L, D, T, G.

b. Enter the following formula:

583.6*T*L/(G*(D^4))

5. Place an AlphaNumeric display to the right of

the Formula object, and change the name to be

Deflection, Deg.

6. Connect the objects as follows:

a. Sequence output pin of Start to sequence input

pin of Length.

b. Data output pins of the constants to the data

input pins of the Formula, as follows:

Length -> L

Diameter -> D

Torque -> T

Shear Modulus -> G

c. Data output pin of Formula to data input pin of

Deflection.

7. Run the model.
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8. Put the following objects into a panel view: Start,

Length, Diameter, Torque, Shear Modulus, and

Deflection.

9. Run the model from the panel view.

10. Save your panel and detail views and clear the work

area.
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Answers to the

Quiz

This model is one of the example models in the

applications directory. To see the model (and check it

against yours):

1. From the File menu, select Open.

2. Enter the name of the example:

a. If you are using HP VEE-Engine, type the

following into the ¬le entry ¬eld:

/usr/lib/veeengine/examples/applications/torsionbar.ex

Make sure your path and ¬lename begin with /,

not ./.

b. If you are using HP VEE-Test, type the following

into the ¬le entry ¬eld:

/usr/lib/veetest/examples/applications/torsionbar.ex

Make sure your path and ¬lename begin with /,

not ./.

3. Click on the Detail button.

You should see the model shown in Figure 3-8.
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Figure 3-8. Torsion Bar Example

3-24 Creating Models



3

What's Next? For more information about any topic in this manual,

refer to Using HP VEE .

If you have HP VEE-Engine, you are ¬nished working

through this manual. Now that you're familiar with

HP VEE's terminology, interface, and basic modeling

techniques, you're ready to build your own models with

HP VEE.

If you have HP VEE-Test, go to the next chapter.
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Exploring Instruments in HP VEE-Test

HP VEE-Test includes the ability to communicate with

test and measurement instruments. This ability is

supported by HP VEE-Test only; it is not supported by

HP VEE-Engine.

HP VEE-Test contains objects that communicate

with instruments directly (with Direct I/O objects)

or through drivers (with State Driver or Component

Driver objects). If you have an instrument for which

HP VEE-Test does not supply a driver, you can access

it with a Direct I/O object. Please refer to Using HP

VEE for information on Direct I/O and Component

Driver. This chapter shows you how to use State

Driver objects.

This chapter contains three exercises which show you

how to use instruments within your HP VEE-Test

model:

1. \Con¬guring Instruments"

2. \Using State Drivers Interactively"

3. \Using State Drivers in a Model"

It will take you about 30 minutes to complete the

exercises in this chapter.
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Note Before you can communicate with instruments, your

computer must be con¬gured with both the proper

HP-UX interface (or kernel) drivers and /dev ¬les to

support the interfaces you use. Check with your system

administrator to see if your computer is con¬gured for

HP-IB instruments, which are used in the examples in

this chapter. Guidelines for con¬guring device drivers

are given in Installing HP VEE .

4-2 Exploring Instruments in HP VEE-Test



4

Exercise 1:

Configuring

Instruments

In this exercise you will con¬gure an HP 3325B Function

Generator and add it to the list of instruments from

which you can later choose for your models.

Please work through this exercise even if you do not

have an HP 3325B Function Generator connected to

your computer; from it you will learn the basics of how

to con¬gure an instrument. You will use this, a State

Driver object, in Exercises 2 and 3.

1. From the I/O menu, select Configure I/O. You

will see a list box containing the already-con¬gured

instruments.

Please do not delete fgen, dvm, or scope from the list,

now or later, since these drivers are used in example

models using instruments.

2. Click on the Add button. You will see a dialog box

similar to the following.

Figure 4-1. Configuring a State Driver

Exploring Instruments in HP VEE-Test 4-3



4

You will edit the ¬elds in this dialog box to add a

function generator to your list of instrument drivers.

Note When changing the values, do not press •Return¶ as that

will cause you to exit the dialog box. Instead, when you

have edited a ¬eld, use the •Tab¶ key to move to the next

¬eld (•Shift-Tab¶ to move to the previous ¬eld), or click on

the ¬eld you need to edit next.

3. Click on the Name ¬eld and type Func-Gen

(remember, do not use the •Return¶ key).

4. Click on the work ON in the Live Mode ¬eld to change

the value from ON to OFF. In HP VEE, instruments

not in Live Mode do not need to be connected to the

computer. This means you can build models using

instruments you don't currently have connected to

your workstation.

Note When you work with a live instrument, you will set the

Address value to be that of the actual address of the

instrument.

5. Click on the Instrument Driver Config button. You

will see a dialog box that you will use to con¬gure

Func-Gen as a state driver instrument.

6. Click on ID Filename. Now you will see a list box

containing a scrollable list of instrument driver ¬le

names.
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Figure 4-2. ID Filename List Box

Scroll the list until you see the ¬le named

hp3325b.cid. Click on the ¬le name and then click

on the OK button at the bottom of the dialog box.

7. Click on OK to close the Instrument Driver

Configuration box and return to the Device

Configuration dialog box. Notice that hp3325b now

appears as the Device Type.

8. Click on OK to return to the Configure I/O Devices

dialog box. You will see the new driver choice,

Func-Gen.

9. Click on Save. The Configure I/O Devices dialog

box will disappear. You have con¬gured a State

Driver instrument. The driver con¬guration is saved

with the other drivers in a ¬le called .veeio in your

HP-UX $HOME (login) directory.
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On Your Own If you have an HP 3325B Function Generator

connected to your computer, set the Address ¬eld to

the HP-IB address to which the instrument is set (the

factory default is 717). To do this, Edit the Func-Gen

driver from the Configure I/O Devices dialog box.

Con¬gure an instrument that you have connected to

your workstation.
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Exercise 2:

Using State

Drivers

Interactively

The open view of a State Driver object in HP

VEE-Test represents the front panel that you see on your

physical instrument. Just as you can change the settings

on your physical instrument's panel, you can change the

settings on your HP VEE-Test instrument's panel. In

this exercise you will see how to use the State Driver

object interactively.

1. From the I/O menu, select Instrument. The device,

Func-Gen, that you con¬gured in the previous section

appears in the dialog box.

2. Select Func-Gen by clicking on it, then clicking on

State Driver.

The pointer changes to a pair of glasses while HP

VEE \looks" for the driver ¬le.

3. Place the object for the Func-Gen on the right side of

your work area.

You see the main panel for this instrument driver.

This panel works exactly the same way as the front

panel on the instrument itself.

Figure 4-3. Main Panel for HP 3325B State Driver

4. Click on Sine. You see a dialog box of choices for the

shape of the Function.
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5. Double-click on Square.

The Function ¬eld changes from Sine to Square.

If this instrument was connected, the address

con¬gured into the driver, and Live Mode set to ON,

this and every action you performed on the object

would occur on the physical instrument itself.

6. Click on the Main Panel ¬eld.

The dialog box you see lists the panels for this

particular instrument. Each panel contains additional

functionality for the instrument.

7. Go to another panel, such as the Sweep or

Modulation panel, to see what is on that panel. To

do this, either double-click on the panel's name in the

dialog box, or click on the panel's name and then click

the OK button.

The panel you selected appears in place of the main

panel.

8. Return to Main Panel by clicking on the panel ¬eld

and selecting Main Panel from the dialog box.

Adding an Input to

Your State Driver

Object

To programmatically change instrument panel settings,

you need to add inputs to the object. The following

exercise shows you how to add an input to your

instrument panel and set values.

1. Open the object menu.

2. From the Add Terminals cascading menu, click on

Select Input Component.

You see the following message in the message box on

top of the HP VEE-Test window: Component for

input?
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3. Click on the value in the Frequency ¬eld (do not

click on the word Frequency). You will see a new

input terminal, FREQUENCY (Real). You've created an

input that will specify the frequency of this function

generator. The data type of the input is Real.

Figure 4-4. HP 3325B with an Added Input

On Your Own Change the values on Func-Gen.

Display the About panel.

Add a PHASE input.

Delete the PHASE input. (Hint: look on the object

menu, the Terminals cascading menu)

When you're ¬nished with this exercise, leave the

Func-Gen object on the work area. You will use it in the

next exercise.
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Exercise 3:

Using State

Drivers in a Model

If you have an HP 3325B Function Generator connected

to your computer and have it con¬gured into HP VEE,

you can see the following interaction on the instrument.

If not, what you see on the HP VEE screen is exactly

what you would see on your physical instrument.

1. From the Flow menu, select Start and place it in the

upper left of the work area.

2. From the Flow menu, across the Repeat cascading

menu, select For Range and place it below Start. Set

the following values:

a. From: 10k

b. Thru: 100k

c. Step: 10k

3. From the Device menu, select Delay and place it

above Func-Gen. Set the delay value to .3. This is in

units of seconds.

4. Connect the model as shown in the Figure 4-5.
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Figure 4-5. Instrument Example

5. Click on Start.

Watch the Frequency ¬eld in Func-Gen. Notice that

it steps from 10 k to 100 k, as you speci¬ed in the For

Range object.

6. If you have an HP 3325B Function Generator

connected to your computer, change Func-Gen to live

mode and specify the correct HP-IB address if you

have not already done so. To make these changes,

go back to the I/O =) Configure I/O feature.

These changes will automatically be re­ected in the

Func-Gen object.
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When you have made the changes, click on Start.

Notice that the Frequency readout ¬eld on both your

HP 3325B Function Generator, and on the Func-Gen

panel, steps from 10 k to 100 k.

On Your Own From the Func-Gen object, change other settings to

see what e«ect it has on your HP 3325B Function

Generator.

If you have any other instruments con¬gured or

connected, select that instrument object and interact

with the instrument.

What's Next? Now that you're familiar with using instruments in HP

VEE-Test, you're ready to build your own testing models

with HP VEE. Refer to Using HP VEE to learn the

details about the following features:

State Drivers

Component Drivers

Direct I/O

For more information about any topic in this manual,

refer to Using HP VEE . For object-speci¬c information

go refer to the HP VEE Reference manual.
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Common Problems

If you have any problems while doing the exercises in

this manual, refer to the following table for possible

rescue procedures to follow. If you cannot ¬nd the

problem listed here, please refer to the Using HP VEE

manual.

Common Problems and Possible Rescues

Problem Rescue Procedure

You selected the

wrong feature

from a menu, and

you need to undo

what you

selected.

If by selecting the wrong feature you got:

A dialog box: click on the Cancel button in the dialog box. The dialog

box will close. If you get a second dialog box, click on Cancel to close

the second dialog box. You can now select the correct feature.

An object outline box: you must remove the object. If you have not

already done so, move the outline box into the work area and click the

mouse button to place the object in the work area. Bring up the object

menu by moving the pointer over the object and pressing the right

mouse button. Then, from the object menu, select Cut.

A prompt at the top of the HP VEE window telling you to do some

action: simply move the pointer into the work area and click the mouse

button to end the feature. You can now select the correct feature.

You've selected

line-draw mode

accidentally.

Position the pointer over an empty area of the work area and double-click

the left mouse button to delete the line.
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Common Questions and Possible Rescues (continued)

Problem Rescue Procedure

You are trying to

draw a line, but

keep moving the

object instead.

If your pointer is on the object, click farther away from the object's pin.

If your pointer is too far from the object, and you are scrolling the work

area, click closer to the object's pin.

A model is not

running as you

expected.

From the Edit menu, select Show Data Flow and Show Exec Flow. Now

when you run the model, you can see which objects are operating and in

what order they are operating.

You need to

delete a data

input or output

pin.

Move the pointer over the object, and press the right mouse button to

bring up the object menu. From the object menu, to the Terminals

cascading menu, select Delete Input or Delete Output.

When you start

to pull down a

menu after

clicking on it, it

disappears.

Do either of the following:

After you click on the menu title, wait a little longer before you pull

down to see menu features.

Drag the menu down (keep the mouse button down as you select the

menu and pull down for the choices). In this case, you select the feature

by releasing the mouse button when it is over the feature that you want

to select.

A line won't

connect to the

pin of an object.

You must get close enough so the line box jumps to the pin. Another

possible reason for non-connection is that the pin may be already

connected (there can be only one connection per input pin).
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Common Questions and Possible Rescues (continued)

Problem Rescue Procedure

You've

accidentally

removed (or cut)

an object.

Under the Edit menu, select Paste. Once your object reappears,

re-connect the lines. This will only work for the last object(s) cut.

HP VEE seems

\frozen" and will

not accept any

input from your

mouse or

keyboard.

1. Make sure there is no dialog box open, or prompt in the title bar, in the

HP VEE window that is waiting for your input. If there is one, answer

the dialog box or prompt as appropriate. This will \unfreeze" HP VEE.

2. If there is no dialog box or prompt, move the pointer into the main

HP VEE window, if possible. Then press the following two keyboard

keys simultaneously: •CTRL - C¶. This should \unfreeze" HP VEE.

3. If HP VEE still will not accept any input, you will have to close the

HP VEE window by using the X11 window menu. Please note, however,

that doing so will cause you to lose all your work and data back to the

point of your last save.

To close the X11 window, move your pointer over the object menu

button in the top, upper left corner of the HP VEE window, press and

hold the left mouse button, highlight Close, and release the left mouse

button to select it.

To run HP VEE again, follow the procedures in \Exercise 1: Starting

HP VEE" in Chapter 2.
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Glossary

This Glossary contains the de¬nitions of terms used

in this guide. For other de¬nitions that describe

graphical objects and processes in HP VEE, refer to

the Using HP VEE manual.

Application

A software program that completes work directly for

the user. For example, HP VEE-Engine is a general

purpose engineering application, and HP VEE-Test

is a test and measurement application.

Array

A data shape that contains a systematic arrangement

of data items in one or more dimensions. The data

items are accessed via indexes. See also Data Shape.

Arrow

1. An arrow-shaped pointer. See Pointer.

2. A scroll arrow that is a part of a scroll bar and is

used either to scroll a list box, or to pan the work

area.

Button

1. A button on a mouse. See Mouse Button.

2. A graphical object in HP VEE that simulates a

real-life pushbutton and appears to pop-out from

your screen. When a button is \pressed" in HP VEE,

by clicking on it with a mouse, an action occurs.
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Cascading Menu

A submenu on a pull-down or pop-up menu that

provides additional selections to a menu selection

(feature).

Checkbox

A recessed square box on HP VEE menus and dialog

boxes that allows you to select a setting. To select

a setting, click on the box and a checkmark appears

in the box to indicate a selection has been made. To

cancel the setting, simply click on the box again to

remove the checkmark.

Click

To press and release a mouse button quickly.

Clicking usually selects a menu feature or object in

the HP VEE window. See also Double-Click and

Drag.

Component Driver

An instrument control object that reads and writes

values to components you speci¬cally select. Use

Component Drivers to control an instrument using a

driver by setting the values of only a few components

at a time. See also Driver Files and State Driver.

Con¬gure

To arrange or modify software, hardware, or both in

a computer system. In HP VEE, a menu selection

with which you may change transaction array

formats, the number of elements in a constant, and so

forth.
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Crosshairs

A cross-shaped pointer in HP VEE that indicates

that the software is waiting for your action. For

example, when you see the crosshairs, you can select

an object in the work area to perform some action

on it, select a menu feature, or select any of the

window controls (such as the scroll arrows, minimize

or maximize buttons, and so forth).

Cursor

A white rectangular pointer in an entry ¬eld that

shows where alphanumeric data will appear when you

type information from the keyboard.

Data Flow

The direction in which data moves in HP VEE. Data

­ow is from left to right through an object, then from

the data output pin of that object to the data input

pin of the next object. Compare with Sequence Flow.

Data Input Pin

A connection point on the left side of an object that

permits data to ­ow into the object.

Data Output Pin

A connection point on the right side of an object that

propagates data ­ow to the next object and passes

the results of the ¬rst object's operation on to the

next object.

Data Shape

A pre-de¬ned structure that de¬nes how data is

grouped together. See also Array and Data Type.

Data Type

A pre-de¬ned structure that determines how data is

organized and treated by HP VEE, and supports

common engineering constructs. See also Data Shape.
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Default

A value or action that HP VEE automatically selects.

Detail View

A view of a model in HP VEE that shows all the

objects and the lines between them. Compare with

Panel View.

Dialog Box

A secondary window displayed when HP VEE

requires information from you before it can continue.

For example, a dialog box may contain a list of ¬les

from which you must choose a ¬le before HP VEE

can perform a particular operation.

Directory

A collection of ¬les. For example, your HP-UX

/users directory usually contains all the ¬les you

have created.

Double-Click

To press and release a mouse button twice in rapid

succession. Double-clicking is usually a short-cut to

selecting and performing an action.

Drag

To press and continue to hold down a mouse button

while moving the mouse. Dragging moves something

(for example, an object or scroll slider) within the

HP VEE window. A drag ends when you release the

mouse button.

Driver

Software that allows a computer to communicate

with other software or hardware more easily than

with raw reads and writes. See also Component

Driver, Driver Files, Interface Driver, and State

Driver.
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Driver Files

A set of ¬les included with HP VEE-Test that

contain the information needed to create State

Driver and Component Driver objects for instrument

control. These ¬les (.cid ¬les) are copied to your

system's hard disk automatically when you install HP

VEE-Test.

Edit

To make changes in a ¬le or entry ¬eld containing

text or data.

Entry Field

A ¬eld that is typically part of a dialog box or an

editable object and is used for text entry. An entry

¬eld appears recessed. For example, the open view of

the For Range object has entry ¬elds where you type

values that specify the beginning, ending, and step

values.

Error Message

Information that explains that a problem has

occurred and appears in a special type of dialog box

in the HP VEE window.

Execute

The action of a model, or parts of a model, running.

Execution Flow

The order in which objects operate. See also Data

Flow and Sequence Flow.

Feature

An item on a menu that you select to cause a

particular action to occur (for example, to open a

¬le), or to get a particular object.

File

A set of information (such as a model or data) that is

stored in an area of computer storage.
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Flow

See Data Flow, Execution Flow, and Sequence Flow.

Grayed Feature

A menu feature that is not currently available for use.

For example, Move Object is grayed when no objects

are selected.

Highlight

1. The colored band or shadow around an object that

provides a visual cue to the status of the object.

2. The change of color on a menu feature that

indicates you are pointing to that feature.

HP-UX

Hewlett-Packard Company's enhanced version of the

UNIXTM operating system. (UNIX is a registered

trademark of UNIX System Laboratories Inc. in the

U.S.A. and other countries.)

Icon

The small, graphical representation of an HP VEE

object, such as the representation of an instrument, a

control, or a display. Compare with Open View.

Instrument Driver

This term is not used in HP VEE. See Driver Files,

Component Driver, and State Driver.

Interface Driver

Software that allows a computer to communicate

with a hardware interface, such as HP-IB or RS-232.

Also called \device driver" in the HP-UX operating

system, interface drivers are con¬gured into the

kernel of the operating system.

Label

The text area or name on an icon or button that

identi¬es that object or button.
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Library

A collection of often-used objects or small models

grouped together for easy access.

Line

A link between two objects in HP VEE.

Log In

The process of typing in a valid user name and its

associated password (if one exists) to gain access to a

computer system.

Login

A valid name and password (if one exists) that you

use to log in to a computer system.

Main Menu

A menu accessed from the HP VEE title bar. The

main menu may be opened by clicking or dragging on

the menu titles in the menu bar.

Main Work Area

The area where you create a model.

Maximize

To enlarge a window to its maximum size. You

maximize a window by selecting the square button on

the right side of the window's title bar. In HP VEE,

the UserObject has a maximize button.

Menu

A collection of features that are presented in a list.

See also Cascading Menu, Main Menu, Object Menu,

Pop-Up Menu, and Pull-Down Menu.

Menu Bar

A rectangular bar at the top of the HP VEE window

that contains titles of the pull-down, main menus

from which you select features.
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Menu Title

The name of a menu within the HP VEE menu bar.

For example, File or Edit.

Minimize

1. To reduce an open view of an object to its

smallest size|an icon.

2. To reduce an X window to its smallest size|an

icon.

Model

In HP VEE, a set of objects connected with lines

that simulates an engineering problem and, when

run, provides a solution to that problem. You build,

modify, and run models in HP VEE by selecting

objects from menus and connecting them in the work

area.

Mouse

A pointing device that you move across a surface to

move a pointer within the HP VEE window.

Mouse Button

One of the buttons on a mouse that you can click,

double-click, or drag to perform a particular action

with the corresponding pointer in the HP VEE

window.

Object

A graphical representation of an element in a

model, such as an instrument, control, display, or

mathematical operator. An object is placed on the

work area and connected to other objects to create a

model. Objects can be displayed as icons or as open

views. See Icon and Open View.
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Object Menu

The menu associated with an object that contains

features that operate on the object such as moving,

sizing, copying, deleting, and adding inputs to the

object. It is accessed by clicking on the upper-left

corner of an open view or clicking the right mouse

button on any non-¬eld area on the object.

Open

To start an action or begin working with a text,

data, or graphics ¬le. When you select Open from

HP VEE, a model is loaded into the work area.

Open View

The representation of an HP VEE object that is

more detailed than an icon. Within the open view,

you can modify the operation of the object and

change the object's title. Compare with Icon. See

also Object.

Operate

The action of an object processing data and

outputting a result. An object operates when it's

data and sequence input pins have been activated.

Outline Box

A box that represents the outer edges of an object or

set of objects and indicates where the object(s) will

be placed in the work area.

Panel

Information displayed in the center of the object's

open view. In a UserObject, the panel contains a

work area. In a For Count object, the panel contains

an entry ¬eld. Compare with Panel View.
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Panel View

The view of a model in HP VEE that shows only

those objects needed for the user to run the model

and view the resultant data. You create a panel

view to meet the needs of your users. Compare with

Detail View and Panel.

Pin

An external connection point on an object to which

you can attach a line. See also Data Input Pin, Data

Output Pin, Sequence Input Pin, Sequence Output

Pin, and Terminal.

Pointer

The graphical image that maps to the movement of

the mouse. A pointer allows you to make selections

and provides you feedback on a particular process

underway. HP VEE has pointers of di«erent shapes

that correspond to process modes, such as an arrow,

crosshairs, and hourglass. See also Arrow and

Crosshairs. Compare with Cursor.

Pop-Up Menu

A menu that provides no visual cue to its presence,

but simply pops up when you perform a particular

action. For example, the Edit menu in HP VEE

pops up when you position the pointer in the work

area and then click the right mouse button.

Pull-Down Menu

A menu that is pulled down from the menu bar when

you position the pointer over a menu title and click

or drag the left mouse button.

Restore

To return a minimized window (an icon) to its full

size as an open view by double-clicking on it.
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Run

To start operating the objects on a model.

Save

To write a ¬le to a storage device, such as a hard

disk, for safekeeping.

Scalar

A data shape that contains a single number. See also

Data Shape.

Scroll

The act of using a scroll bar either to move through a

list of data ¬les or other choices in a dialog box or to

pan the work area.

Scroll Arrow

An arrow that is part of a scroll bar and, when

clicked on, moves you through a list of data ¬les or

other choices in a dialog box or pans the work area.

Scroll Bar

A graphical device used either to move through a list

of data ¬les or other choices in a dialog box or to pan

the work area. A scroll bar consists of one or more

scroll sliders and scroll arrows.

Scroll Slider

A rectangular bar that is part of a scroll bar and,

when dragged, moves you through a list of data ¬les

or other choices in a dialog box or pans the work

area.

Select

To choose an object, an action to be performed, or a

menu item. Usually you select by clicking with your

mouse.
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Selection

1. A menu selection (feature).

2. An object or action you have selected in the

HP VEE window.

Sequence Flow

The direction in which sequence impulses move in

HP VEE, which is from the top to the bottom within

an object, and from the sequence output pin of one

object to the sequence input pin of another object,

and so on. See also Data Flow.

Sequence Input Pin

The top pin of an object. When connected, this

input pin must be activated before the object will

operate.

Sequence Output Pin

The bottom pin of an object. When connected, this

output pin is activated when the object and all data

­ow propagation from that object ¬nishes executing.

Software

Computer programs (applications) that let users

perform speci¬c tasks with the computer.

State Driver

An instrument control object that forces all the

function settings in the corresponding physical

instrument to match the settings in the control panel

displayed in the open view of the object. See also

Component Driver and Driver Files.

Terminal

The internal representation of a pin that displays

information about the pin and the data held by the

pin.
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Title Bar

The rectangular bar at the top of the HP VEE

window or the object's open view where the model's

or object's name is shown.

User Interface

The part of an application that permits a user and

the application to communicate with each other to

perform certain tasks. HP VEE uses a graphical user

interface, which includes windows, menus, dialog

boxes, and objects.

UserObject

An object that can encapsulate a group of objects

that perform a particular function. A UserObject

allows you to use top-down design techniques when

building a model and to build user-de¬ned objects

that can be saved in a library and reused.

View

See Detail View, Icon, Open View, and Panel View.

Window

A rectangular area on the screen that contains a

particular application program, such as HP VEE or

the HP-UX shell.

Window Frame

The area surrounding a window that contains a

resize border, window menu button, minimize and

maximize buttons, and a title area.

Work Area

The area within the HP VEE window or the open

view of a UserObject where you group objects

together. When you open a model, it is loaded into

the main work area. The panel of a UserObject is a

work area. See also Panel.
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X Window System (X11)

An industry-standard windowing system used on

HP-UX computer systems.
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Index

A Add button, 4-3

adding inputs, 2-26

adding inputs to an instrument object, 4-8

adding instruments, 4-3

AlphaNumeric object, 3-15, 3-17

Any data type, 3-15

areas of the HP VEE window, 2-4

arrays, 3-17

arrow, 2-7

B buttons

Add, 4-3

Cancel, 2-27

Cont, 3-4

Detail, 3-12

Instrument Driver Con¬g, 4-4

OK, 2-2{3, 2-16, 2-35, 3-5, 4-5, 4-8

Panel, 3-12

Run, 2-33

Start, 2-12, 3-16

Step, 3-4

C Cancel button, 2-27

cascading menu, 2-8

change instrument panel settings, 4-8

changing from one data type to another, 3-15

changing the name in the HP VEE title bar, 2-23

check box, 3-3

choosing features, 2-6

choosing menus, 2-6

choosing type of instrument, 4-5
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Clear (don't save) feature, 2-21

clearing the work area, 2-21

Clone feature, 2-16

closing a menu, 2-8

communicating with instruments, 4-2

Complex object, 3-15

Con¬g I/O Devices feature, 4-3

con¬guration menu, 2-7

con¬guring instruments, 4-3

connecting objects, 2-29

connecting objects, problems, 5-2

Cont button, 3-4

converting data types, 3-15

creating a UserObject, 3-8

crosshairs, 2-5

Cut feature, 2-13, 5-1

cutting multiple objects, 2-18

cutting objects, 2-12

D data conversion, 3-15

data ­ow, 2-29, 3-3

data pin

adding, 2-26, 2-31

adding to instrument, 4-8

connecting, 2-30

deleting lines between, 2-34

description, 2-25

drawing lines between, 2-30

input, 2-25{26, 3-3

output, 2-25, 3-3

removing, 5-2

terminal information, 2-26

data shapes, 3-17

data type conversion, 3-15

data types

Any, 3-15

converting, 3-15

deleting

lines, 2-34

multiple objects, 2-18

objects, 2-12, 5-1
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description of HP VEE, 1-1

deselecting objects, 2-12

Detail button, 3-12

details of object, 2-22

detail view, 3-12

Device menu, 2-22, 3-2

dialog box

Cancel button, 2-27

description, 2-9

Help, 2-9

Input Terminal Information, 2-26

OK button, 2-35

Open File, 2-3

removing, 5-1

Save File, 2-2, 2-35

Direct I/O, 4-1

disconnecting objects, 2-34

displaying objects, 2-28

Display menu, 2-28, 3-2

double-clicking, 2-24

dragging (moving) the work area, 2-20

dragging the pointer, 2-15

drawing lines, 2-30

driver, 4-1

E Edit menu, 2-13{14, 2-17, 2-34, 3-3, 3-8, 3-12

ending a work session, 2-35

examples directory, 3-19

executing a model, 2-33

execution ­ow, 3-3

execution rules, 3-4, 3-7

Exit feature, 2-2, 2-36

exiting HP VEE, 2-2, 2-35, 5-3

exiting line drawing mode, 2-30, 5-1

expanded view of object, 2-22
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F features

Clear (don't save), 2-21

Clone, 2-16

Con¬g I/O Devices, 4-3

Cut, 2-13, 5-1

Direct I/O, 4-1

Exit, 2-2, 2-36

highlighting, 2-7

Instrument, 4-7

Move, 2-15

New, 2-21

not available, or grayed, 2-7

On Features help, 2-10

Open, 2-3

Paste, 2-13

Save As, 2-2, 2-35

selecting, 2-6

Select Objects, 2-17

Show Description, 2-16

Show Exec Flow, 3-3

Show Terminals, 2-27

Size, 2-15

State Driver, 4-1

File menu, 2-2{3, 2-6, 2-35

¬le-related menu items, 2-7

Flow menu, 2-12, 3-2

For Count object, 3-2

For Range object, 3-17

From File object, 3-6

Function Generator object, 2-22

G getting your model, 2-3

grayed features, 2-7

grouping objects, 3-8
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H Help menu, 2-9

highlighting features, 2-7

HP-UX,prerequisites, 1-5

HP VEE end user's interface, 3-12

HP VEE examples directory, 3-19

HP VEE won't run, 5-3

I icon, 2-22

expanding to an open view, 2-22

getting object menu, 2-13

getting pop-up Edit menu, 2-14

opening, 2-22

removing, 5-1

input

adding to an instrument object, 4-8

adding to an object, 2-26

input terminal, 2-26, 4-8

instrument, 4-1

actions, 4-8

adding inputs, 4-8

change panel settings, 4-8

choosing type, 4-5

communicating with, 4-2

con¬guring, 4-3

main panel, 4-8

open view, 4-7

panels, 4-8

selecting, 4-7

Instrument Driver Con¬g button, 4-4

Instrument feature, 4-7

I/O menu, 4-3

L line drawing mode

drawing lines, 2-30

exiting, 2-30, 5-1

line won't connect, 5-2

list box, 2-10

From File, 3-7

OK button, 3-5

To File, 3-5
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live mode, 4-4

logging o«, 2-2

M main panel of instrument, 4-8

manipulating multiple objects, 2-17

median(x) object, 3-17

menu

cascading, 2-8

closing, 2-8

con¬guration, 2-7

Device, 2-22, 3-2

Display, 2-28, 3-2

Edit, 2-13{14, 2-17, 2-34, 3-3, 3-8, 3-12

File, 2-2{3, 2-6, 2-35

¬le-related, 2-7

Flow, 2-12, 3-2

Help, 2-9

I/O, 4-3

object, 2-13

opening, 2-6

pop-up, 2-14

pop-up Edit, 2-14

pop-up object, 2-13

pull-down, 2-6

pull-down Edit, 2-14

selecting features, 2-6

Virtual Source, 2-22

minimize, 2-23

minimize button, 2-23

minimized view, 2-23

models

description, 1-2

example, 1-2

example models, 3-19

executing, 2-33

objects, 2-12

running, 2-33

saving, 2-2, 2-36

starting, 2-33

mouse

clicking, 2-6
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double-clicking, 2-24

dragging the pointer, 2-15

pointer, 2-5

using in HP VEE, 2-5

Move feature, 2-15

moving

an object, 2-15

multiple objects, 2-17

the work area, 2-19

N name of object, changing, 2-23

New feature, 2-21

no response from mouse or keyboard, 5-3

O + object, 3-15

object menu, 2-13

opening, 2-26

objects

+, 3-15

AlphaNumeric, 3-15, 3-17

changing the name, 2-23

Complex, 3-15

connecting, 2-29

cutting, 2-12

cutting multiple, 2-18

data ­ow, 2-29

deleting, 2-12

description, 2-12

deselecting, 2-12, 2-14

details (open view), 2-22

disconnecting, 2-34

displaying, 2-28

dragging, 2-15

drawing lines between, 2-30

For Count, 3-2

For Range, 3-17

From File, 3-6

Function Generator, 2-22

icon, 2-22

instrument, 4-1, 4-8
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median(x), 3-17

moving, 2-15

moving multiple, 2-17

moving the work area, 2-19

object menu, 2-13

open view, 2-22

operating on, 2-13

pasting, 2-12, 2-18

Random Number, 2-37, 3-2

Real, 3-15

Real Slider, 2-31

recovering, 2-12

removing, 2-12, 3-7, 5-1

removing all from work area, 2-21

selecting, 2-12

Show Description feature, 2-16

Sliding Collector, 3-17

Start, 2-12

To File, 3-5

undeleting, 2-12

Until Break, 2-37

UserObject, 3-8

Waveform (Time), 2-28

X vs Y Plot, 2-37

XY Trace, 3-2

OK button, 2-2{3, 2-16, 2-35, 3-5, 4-5, 4-8

On Features help feature, 2-10

Open feature, 2-3

opening menus, 2-6

opening the object menu, 2-26

opening your model, 2-3

open view, 2-22

open view of an instrument, 4-7

operating on an object, 2-13

operation sequence, 2-25
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P Panel button, 3-12

panel, instrument, 4-8

panel view, 3-12{14

Paste feature, 2-13

pasting objects, 2-12, 2-18

pin

data, 2-25

sequence, 2-25

pointer

changing into an arrow, 2-7

changing into crosshairs, 2-5

dragging, 2-15

+ (plus), 2-5

selecting an X window, 2-4

pop-up Edit menu, 2-14

pop-up object menu, 2-13

prerequisites for running HP VEE, 1-5

problems

accidentally removed an object, 5-2

accidentally selected line-draw mode, 5-1

connecting objects, 5-2

HP VEE screen disappears, 5-3

line won't connect to the pin, 5-2

model not executing as expected, 5-2

need to delete a data input or output pin, 5-2

no response from mouse or keyboard, 5-3

pull-down menu disappears, 5-2

removed an object by mistake, 2-13

wrong feature, 5-1

programmatically change instrument panel settings, 4-8

propagation rules, 3-4, 3-7

pull-down Edit menu, 2-14

pull-down menu, 2-6

pull-down menu disappearing, 5-2
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R Random Number object, 2-37, 3-2

Real object, 3-15

Real Slider object, 2-31

recovering objects, 2-12, 2-18, 5-2

removing

all objects from work area, 2-21

data pin, 5-2

dialog box, 5-1

icon, 5-1

lines, 2-34

multiple objects, 2-18

objects, 2-12, 3-7, 5-1

repositioning objects, 2-19

resizing an object, 2-15

retrieving your model, 2-3

rules

data ­ow, 3-3

execution, 3-4, 3-7

Run button, 2-33

running a model, 2-33

running HP VEE

execution ­ow, 3-3

how to exit, 2-2, 5-3

how to start, 2-4

prerequisites, 1-5

retrieving your model, 2-3

rules, 3-2

saving your model, 2-2, 2-35

using a mouse, 2-5

S Save As feature, 2-2, 2-35

saving your model, 2-2, 2-35

scalars, 3-17

scroll arrows, 2-20

scrolling the work area, 2-20

selecting

features, 2-6

instrument, 4-7

menu features, 2-6

multiple objects, 2-17

objects, 2-12

Index-10



Select Objects feature, 2-17

sequence of operation, 2-25

sequence pin

description, 2-25

Show Data Flow feature, 5-2

Show Description feature, 2-16

Show Exec Flow feature, 3-3, 5-2

showing details of object, 2-22

Show Terminals feature, 2-27

Size feature, 2-15

Sliding Collector object, 3-17

Start button, 3-16

starting a model, 2-33

starting HP VEE, 2-4

Start object, 2-12

State Driver, 4-1

Step button, 3-4

stopping a model, 2-40

stopping HP VEE, 2-2, 2-35

T terminal information, 2-26

Terminals feature, 2-26

title of object, changing, 2-23

To File object, 3-5

U undeleting objects, 2-12, 2-18

Until Break object, 2-37

UserObject, 3-8

using a mouse in HP VEE, 2-5

V views

detail, 3-12

icon (minimized view of an object), 2-22

open view of an object, 2-22{27, 2-28, 4-7

panel, 3-12{14

view to the work area, 2-19

Virtual Source menu, 2-22

Index-11



W Waveform (Time) object, 2-28

window

description of areas, 2-4

moving the work area, 2-20

scroll arrows, 2-20

work area

clearing, 2-21

dragging, 2-20

moving, 2-19

removing all objects, 2-21

scrolling, 2-20

view, 2-19

X X11, prerequisites, 1-5

X vs Y Plot object, 2-37

XY Trace object, 3-2
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